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Introduction

Copyright statement

Copyright © 2020

Nanjing Decowell Automation Co., LTD. All rights reserved.Without the written permission of
the Company, no unit or individual is allowed to extract or reproduce the contents of this
document in part or in whole, and shall not be transmitted in any form.

All are trademarks of our company.Other

registered trademarks appearing in this document shall be owned by their respective owners.

Due to product version upgrade or other reasons, the contents of this document will be updated
from time to time.Except as otherwise agreed, this document is for reference only. All statements,
information and recommendations contained in this document do not constitute a warranty of any
kind, express or implied.

The scope of this document

This document is applicable to EX series remote I/O systems

Content introduction

This document describes the technical specifications, installation, and commissioning of EX
series remote I/O modules.The main contents include:

 System Overview: Mainly introduces EX series remote I/O module product ordering
information, product composition, system architecture, product transportation, storage
environment and other contents;

 Product Description: Describes the technical parameters of EX series remote I/O modules.

 Installation and Disassembly Guide: Describes the installation and disassembly of EX series
remote I/O modules.

 Mechanical and Electrical Drawing: EX remote IO module dimension drawing and electrical
wiring diagram;

 Usage Guide: Through examples, the EX series remote I/O module and the communication
between the main PLC connection;

Attention
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This document describes in detail the use of well-Link's EX series remote I/O modules for those
with engineering experience.Nanjing Deckwell shall not be responsible for any consequences
arising from the use of this material.

Before using the device, read the precautions carefully and follow the safety precautions and
operating procedures for installation and commissioning.See the following symbols for the
possible hazards and extent of damage caused by incorrect use of the equipment

Warning
This marker means

"The risk of failure to operate as required may result in personal casualties"

Attention
This marker means

"Failure to operate as required may result in mild or moderate bodily injury and damage to equipment"

Reminder
This marker means

"Make the necessary additions or instructions to the description of the operation"

The applicable objects

This manual provides information on the installation and commissioning of EX series remote I/O
modules. It is designed for engineers, installers, maintenance personnel, and electricians with
automation knowledge.

Recovery and disposal

To ensure that recycling and disposal of used equipment meets environmental requirements,
contact an accredited e-waste service.

Online support

In addition to this manual, you can also refer to the official website for more product information.

http://www.welllinkio.com

http://www.welllinkio.com/
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1 Overview of the EX Remote I/O system

1.1 What is a Distributed I/O System

EX series IO is a highly flexible, scalable distributed I/O module for connecting process
signals to upper controllers via a fieldbus.

1.2 Modules of an EX Distributed I/O System

EX series remote I/O modules are composed of adapter module, I/O module
(digital/analog/function module), power module, and terminal module.

Adapter
Digital module Analog module

Voltage/Current

Term
inalm

odule

Figure 1-1 EX series I/O system architecture

1.3 Features of the EX distributed I/O Module

Relay

 There are various I/O
module models

 One system can satisfy
factory automation and
process automation
control

 Supports a variety of
communication
protocols, such as
EtherCAT-Profinet,
DeviceNET, CC-Link
PROFIBUSDP, Modbus
RTU, CANopen, etc

 Compact module structure,
Save installation space

 Direct plug terminal, Save
system wiring time

 A single IO module supports a
maximum of 32 digital quantity
signal points

 High electrical isolation, stable

communication, data does not

lose packets.

 The adapter can carry up to 32

IO modules

Strong combination Communication protocol

Ease of use Remarkable performance

Voltage/Current
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Figure 1-2 Features of The EX series I/O modules

1.4 Application Domains of EX Distributed I/O

EX series of distributed I/O modules are widely used in various fields, such as new energy,
lithium, non-standard automation, robotics, CNC machine tools, intelligent garage, logistics
sorting, educational equipment, environmental protection, heating, etc.

2 EX Remote I/O Module Parameters

2.1 EX Series Adapters

Adapter module can support a variety of bus communication protocols and achieve seamless
connection with the mainstream PLC; An adapter module can be connected to a maximum of 32
I/O modules and supports a maximum of 1024 signal points. A variety of status diagnosis
functions and status indicators are designed. Screw free terminal, wiring is convenient and
reliable, and the design of 45 degree network port, reduce the stress of network port, increase the
reliability of the product.Through the buttons on both sides of the module, multiple modules can
be fixed to each other, to increase the seismic performance of the system using the standard
DIN35 guide rail installation.

2.1.1 DeviceNet Adapter

 DeviceNet Adapter model and order number

Model Specifications description The order no.

EX-1010 DeviceNet adapter module 02-01-01

EX-1130 Modbus TCP bus adapter 02-01-11
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EX-1030 Modbus RTU adapter module 02-01-03

EX-1100 EtherCAT adapter module 02-01-04

EX-1110 PROFINET adapter module 02-01-05

EX-1040 Cc-link adapter module 02-01-06

EX-1050 CANopen adapter module 02-01-11

EX-1120 EtherNet/IP adapter 02-01-08

EX-1121 EtherNet/IP adapter 02-01-08-1

EX-1140 CC-Link IEFB bus adapter 02-01-09

 DeviceNet Adapter indicator definition

Serial
number

Indicator Instructions Color State Meaning

1 SYS
System
indicator

green

Blinking at
1Hz

Communication is normal

Blinking at
5HZ

I/O lost from the station

One flash one
out

IO module station number
assignment failed

Two flashes
one out

I/O module fails to be
configured

out IO module is not running

2
UNIT
PWR

System power
indicator

green

on
System power supply is

normal

out
System power supply is
not connected or faulty

3 IO PWR
IO power
indicator

green
on

I/O power supply is
normal

out I/O power supply is not
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connected or faulty

4 NET-RUN
Running
indicator

green

on
Communication is normal,

data transmission is
normal

out
Communication stops.
Data transfer stops

5 NET-PWR
Communication

interface
indicator

red

on Communication is normal

out
Communication is

disconnected or abnormal

6 NET-ERR
System failure

indicator
red

on
I/O module system is

faulty

out
I/O module is running

properly

 DeviceNet Adapter communication interface definition

 DeviceNet Adapter Dial Settings

DeviceNet communication interface
Bit

number
Signal Signal definition

Bit number 1

Bit number 2

Bit number 3

Bit number 4

Bit number 5

1 V- Power supply cathode

2 CAN_L Data signal negative

3 SHIELD Shielding wire

4 CAN_H Data signal positive

5 V+ Power supply positive



EX Series Card I/O

Email:contact@welllinkio.com 12

Communic
ation rate
setting

Dial
setting ×
10

Dial
setting
× 1

DeviceNet
Communication rate

setting

0 125kbps

1 250kbps

2 500kbps

 DeviceNet Adapter parameters

Technical parameters

Bus protocol DeviceNet

Address set 0 ~ 63

Expanding the number of I/ OS 32

Maximum input/output bytes -

Bus rate 125, 250, 500kbps

Transmission distance 500 m (Max)

System side power input DC24V (18 to 36)

The system side provides
current

2 a (Max)

Power input of the I/O port DC24V (+ / - 20%)

Output current of the I/O port 10 a (Max)

Power consumption 56mA

Conventional parameters

System side electrical isolation AC500V

Protection against reverse
connection

support

Over current protection This function is supported by the system, but not by the I/O

Over voltage protection support
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Wire specifications 0.2 ~ 1.5 mm squared

Connection mode No screw

Overall dimensions 90 x 67 x 34 mm

Weight 240g

Protection grade IP20

Temperature range
Operating temperature: -10 ~ 55℃, storage temperature:

-20 ~ 85℃

Relative humidity 95% no condensation

2.1.2 Modbus TCP adapter

 Modbus TCP bus adapter model and order number

Model Specifications descrption The order no.

EX-1010 DeviceNet adapter module 02-01-01

EX-1130 Modbus TCP bus adapter 02-01-11

EX-1030 Modbus RTU adapter module 02-01-03

EX-1100 EtherCAT adapter module 02-01-04

EX-1102 EtherCAT adapter module 02-01-04-2

EX-1110 PROFINET adapter module 02-01-05

EX-1040 CC-link adapter module 02-01-06

EX-1050 CANopen adapter module 02-01-11

EX-1120 EtherNet/IP adapter 02-01-08

EX-1121 EtherNet/IP adapter 02-01-08-1

EX-1140 CC-Link IEFB bus adapter 02-01-09

2.1.3 Modbus RTUAdapters

 Modbus RTU adapter model and order number
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model Specifications description The order no.

EX-1010 DeviceNet adapter module 02-01-01

EX-1130 Modbus TCP bus adapter 02-01-11

EX-1030 Modbus RTU adapter module 02-01-03

EX-1100 EtherCAT adapter module 02-01-04

EX-1110 PROFINET adapter module 02-01-05

EX-1040 CC-link adapter module 02-01-06

EX-1050 CANopen adapter module 02-01-11

EX-1120 EtherNet/IP adapter 02-01-08

EX-1121 EtherNet/IP adapter 02-01-08-1

EX-1140 CC-Link IEFB bus adapter 02-01-09

 Modbus RTU adapter indicator definition

Serial

number

Indicator Instructions Color State Meaning

1 SYS System indicator green

Blinking at 1Hz Communication is normal

Blinking at 5HZ I/O lost from the station

One flash one out
IO module station number

assignment failed

Two flashes one

out

I/O module fails to be

configured

out IO module is not running

2 UNIT PWR
System power

indicator
green

on System power supply is normal

out
System power supply is not

connected or faulty

3 IO PWR IO power indicator green on I/O power supply is normal
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out
I/O power supply is not

connected or faulty

4 NET-RUN
Running indicator

light
green

on
Communication is normal, data

transmission is normal

out
Communication stops. Data

transfer stops

5 NET-ERR
System failure

indicator
red

on I/O module system is faulty

out I/O module is running properly

6 NETTX
Data transmission

indicator light
green

on Data transmission in progress

out Data is stopped or abnormal

7 NETRX
Data reception

indicator light
green

flash Data receiving

out Data is stopped or abnormal

 Modbus RTU adapter communication interface definition

 Set dip

switches for the Modbus RTU adapter

Modbus RTU communication interface Bit number signal Signal definition

Bit number 1

Bit number 2

Bit number 3

Bit number 4

Bit number 5

1 A RS485+

2 B RS485-

3 - -

4 - -

5 - -
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Communic
ation rate
setting

Dial
setting ×
10

Dial
setting
× 1

Modbus RTU communication
rate setting

1 115200bps

2 57600bps

3 38400bps

4 19200bps

5 9600 BPS (default)

6 4800bps

7 2400bps

8 1200bps

 Modbus RTU adapter support function code

Function code function Functional meaning note

0x01 Read Read digital quantity output For example, the EX-3XXX module

0x02 Read Read digital quantity input For example, the EX-2XXX module

0x03 Read Read analog output For example, the EX-5XXX module

0x04 Read Read analog input For example, the EX-4XXX module

0x05 Write Write a single numeric quantity For example, the EX-3XXX module

0x06 Write Write a single analog quantity For example, the EX-5XXX module

0x0F Write Write multiple numeric quantities For example, the EX-3XXX module

0x10 Write Write multiple analog quantities For example, the EX-5XXX module

 Modbus RTU adapter communication parameters



EX Series Card I/O

Email:contact@welllinkio.com 17

Technical parameters

Bus protocol Modbus RTU

Address set 0 ~ 99

Expanding the number of I/ OS 32

Maximum input/output bytes Input: 256 Byte/Output: 256 Byte

The bus rate Optional: 1200/2400/57.6/38.4/19.2/4800/9600 k k k / 115.2 k

Transmission distance 1200 m (Max)

System side power input DC24V (18 to 36)

The system side provides current 2 a (Max)

Power input of the I/O port DC24V (+ / - 20%)

Output current of the I/O port 10 a (Max)

Power consumption 69mA

Conventional parameters

System side electrical isolation AC500V

Protection against reverse
connection

support

Over current protection This function is supported by the system, but not by the I/O

Over voltage protection support

Wire specifications 0.2 ~ 1.5 mm squared

Connection mode No screw

Overall dimensions 90 x 67 x 34 mm

Weight 240g

Protection grade IP20

Temperature range Operating temperature: -10 ~ 55℃, storage temperature: -20 ~ 85℃

Relative humidity 95% no condensation
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2.1.4 EtherCATAdapter

 EtherCAT adapter model and order number

Model Specifications description The order no.

EX-1010 DeviceNet adapter module 02-01-01

EX-1130 Modbus TCP bus adapter 02-01-11

EX-1030 Modbus RTU adapter module 02-01-03

EX-1100 EtherCAT adapter module 02-01-04

EX-1110 PROFINET adapter module 02-01-05

EX-1040 Cc-link adapter module 02-01-06

EX-1050 CANopen adapter module 02-01-11

EX-1120 EtherNet/IP adapter 02-01-08

EX-1121 EtherNet/IP adapter 02-01-08-1

EX-1140 CC-Link IEFB bus adapter 02-01-09

 EtherCAT adapter indicator definition

Serial

number

Indicator Instructions Color State Meaning

1 SYS System indicator green

Blinking at 1Hz Communication is normal

Blinking at 5HZ I/O lost from the station

One flash one

out
IO module station number assignment failed

Two flashes one

out
I/O module fails to be configured

out IO module is not running

2 UNIT PWR
System power

indicator
green

on System power supply is normal

out System power supply is not connected or faulty
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3 IO PWR IO power indicator green
on I/O power supply is normal

out I/O power supply is not connected or faulty

4 NET-RUN
Running indicator

light
green

on
Communication is normal, data transmission is

normal

flash Communication initialization complete, pre-run

one flash Installation Run Status

out Initialization status

5 NET-ERR
System failure

indicator
red

on Communication error

two flashes App watchdog timeout

one flash Local error

flash Configuration error

out No Error

6 LINK/ACT1
Indicators of

Network Port 1
green

on The network connection is normal

out Network not connected or abnormal

7 LINK/ACT2
Indicators of

network Port 2
green

on The network connection is normal

out Network not connected or abnormal

 EtherCAT adapter communication interface definition

Ethernet interface Bit number Signal Signal definition

1 TX+ Positive end of data transmission

2 TX- Negative end of data transmission

3 RX+ Positive data receiving end

4 - -

5 - -

6 RX- Data receiving negative end
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7 - -

8 - -

Connector housing PE Chassis grounding

 EtherCAT adapter communication parameters

Technical parameters

Bus protocol EtherCAT

Address set According to the main

Expanding the number of I/ O 32

Maximum input/output bytes Input: 1024 Byte/Output: 1024 Byte

The bus rate 100Mbps

Transmission distance 100m (station to station distance)

System side power input DC24V (18 to 36)

The system side provides
current

2 a (Max)

Power input of the I/O port DC24V (+ / - 20%)

Output current of the I/O port 10 a (Max)

Power consumption 219mA

Conventional parameters

System side electrical isolation AC500V

Protection against reverse
connection

support

Over current protection This function is supported by the system, but not by the I/O

Over voltage protection support

Wire specifications 0.2 ~ 1.5 mm squared

Connection mode No screw

Overall dimensions 90 x 67 x 34 mm
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The weight of the 240g

Protection grade IP20

Temperature range
Operating temperature: -10 ~ 55℃, storage temperature:

-20 ~ 85℃

Relative humidity 95% no condensation

2.1.5 PROFINETAdapter

 PROFINET adapter model and order number

model Specifications description The order no.

EX-1010 DeviceNet adapter module 02-01-01

EX-1130 Modbus TCP bus adapter 02-01-11

EX-1030 Modbus RTU adapter module 02-01-03

EX-1100 EtherCAT adapter module 02-01-04

EX-1110 PROFINET adapter module 02-01-05

EX-1040 CC-link adapter module 02-01-06

EX-1050 CANopen adapter module 02-01-11

EX-1120 EtherNet/IP adapter 02-01-08

EX-1121 EtherNet/IP adapter 02-01-08-1

EX-1140 CC-Link IEFB bus adapter 02-01-09

 PROFINETAdapter indicator definition

Serial

number

Indicator instructions Color State Meaning

1 SYS System indicator green

Blinking at 1Hz Communication is normal

Blinking at 5HZ I/O lost from the station

One flash one out IO module station number assignment
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failed

Two flashes one

out
I/O module fails to be configured

out IO module is not running

2 UNIT PWR
System power

indicator
green

on System power supply is normal

out
System power supply is not connected

or faulty

3 IO PWR IO power indicator green

on I/O power supply is normal

out
I/O power supply is not connected or

faulty

4 NET-RUN
Running indicator

light
green

on
Communication is normal, data

transmission is normal

out
Communication stops, data transfer

stops

5 NET-ERR
System failure

indicator
red

on The network is not connected

flash
The network is connected, PN

communication abnormal

out
The network is connected, PN

communication invalid

6 LINK/ACT1
Indicators of

Network Port 1
orange

on The network connection is normal

out Network not connected or abnormal

7 LINK/ACT2
Indicators of

network Port 2
orange

on The network connection is normal

out Network not connected or abnormal

 PROFINET adapter communication interface definition

Ethernet interface Bit number signal Signal definition

1 TX+ Positive end of data
transmission
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2 TX- Negative end of
data transmission

3 RX+ Positive data
receiving end

4 -- --

5 -- --

6 RX- Data receiving
negative end

7 -- --

8 -- --

Connector
housing

PE Chassis ground

 PROFINETAdapter parameters

Technical parameters

Bus protocol PROFINET

Address set According to the main

Expanding the number of I/
OS

32

Maximum input/output
bytes

Input: 340 Byte/Output: 340 Byte

The bus rate 100Mbps

Transmission distance 100m (station to station distance)

System side power input DC24V (18 to 36)

The system side provides
current

2 a (Max)

Power input of the I/O port DC24V (+ / - 20%)

Output current of the I/O
port

10 a (Max)

Power consumption 270mA
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Conventional parameters

System side electrical
isolation

AC500V

Protection against reverse
connection

support

Over current protection
This function is supported by the system, but not by the

I/O

Over voltage protection support

Wire specifications 0.2 ~ 1.5 mm squared

Connection mode No screw

Overall dimensions 90 x 67 x 34 mm

The weight of the 240g

Protection grade IP20

Temperature range
Operating temperature: -10 ~ 55℃, storage temperature:

-20 ~ 85℃

Relative humidity 95% no condensation

2.1.6 CC-link adapter

 CC-link adapter model and order number

Model Specifications description The order no.

EX-1010 DeviceNet adapter module 02-01-01

EX-1130 Modbus TCP bus adapter 02-01-11

EX-1030 Modbus RTU adapter module 02-01-03

EX-1100 EtherCAT adapter module 02-01-04

EX-1110 PROFINET adapter module 02-01-05

EX-1040 CC-link adapter module 02-01-06

EX-1050 CANopen adapter module 02-01-11
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EX-1120 EtherNet/IP adapter 02-01-08

EX-1121 EtherNet/IP adapter 02-01-08-1

EX-1140 CC-Link IEFB bus adapter 02-01-09

 CC-link Adapter indicator definition

Serial

number

Indicator Instructions Color State Meaning

1 SYS System indicator green

Blinking at 1Hz Communication is normal

Blinking at 5HZ I/O lost from the station

One flash one out
IO module station number

assignment failed

Two flashes one

out

I/O module fails to be

configured

out IO module is not running

2 UNIT PWR
System power

indicator
green

on System power supply is normal

out
System power supply is not

connected or faulty

3 IO PWR IO power indicator green

on I/O power supply is normal

out
I/O power supply is not

connected or faulty

4 NET-RUN
Running indicator

light
green

on
Communication is normal, data

transmission is normal

out
Communication stops, data

transfer stops

5 NET-ERR
System failure

indicator
red

on Cc-link communication error

out
Cc-link communication is

normal
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6 NETTX
Data transmission

indicator light
green

flash Data transmission in progress

out Data is stopped or abnormal

7 NETRX
Data reception

indicator light
green

flash Data receiving

out Data is stopped or abnormal

 CC-link adapter communication interface definition

CC-link Communication

interface
Bit number signal Signal definition

Bit number 1

Bit number 2

Bit number 3

Bit number 4

Bit number 5

1 DA A communications line

2 DB Communication line B

3 DG
Communication

common end

4 SLD Shielding wire

5 FG Chassis ground

 Set the DIP switch for the CC-Link adapter

Communic
ation rate
setting

Dial
setting ×
10

Dial
setting
× 1

Cc-link Communication rate setting

Dial the code

number

Communication

rate

Corresponding

transmission

distance

0 5 156kbps 1200m

1 6 625kbps 600m

2 7 2.5 Mbps 200m

3 8 5Mbps 150m
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4 9 10Mbps 100m

CC-link Dip switch corresponds to the station id

Rate distance

corresponding

to dip station

number

Fixed logic

station

Dial the

code: 0

Dial the

code: 1

Dial the

code: 2

Dial the

code: 3

Dial the

code: 4

Variable

logic station

Dial the

code: 5

Dial the

code: 6

Dial the

code: 7

Dial the

code: 8

Dial the

code: 9

CC-link Communication rate

and transmission distance

156kbps 625kbps 2.5 Mbps 5Mbps 10Mbps

1200m 600m 200m 150m 100m

CC-link Indicates the number of all secondary site bits (I/O and registers)

Number of remote I/O points 2048 DI / 2048 DO

Remote register RWW 256 AO (Master station -> Remote, local station)

Remote register RW r 256 point AI (primary -> Remote, local)

Number of connection points per site

Number of remote I/O points 32 DI points, 32 DO points

Remote register RWW 4AO (Master station -> Remote, local station)

Remote register RW r 4 points AI (Primary -> Remote, local)

CC-link Bus stations/points

Max: 4 Max: 128 DI, 128 DO, 16AI, 16 AO

Maximum number of I/O

modules that can be expanded

by CC-Link bus

4 x (32DI+ 32DO +4AI+4AO)

 CC-link adapter parameters

Technical parameters

Bus protocol CC-Link
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Address set 1-64

Expanding the number of I/
OS

32

Maximum input/output
bytes

Input: 48 bytes /Output: 48 bytes

The bus rate 156 KBPS / 625 KBPS / 2.5 Mbps / 10 Mbps

Transmission distance 1200 m (Max)

System side power input DC24V (18 to 36)

The system side provides
current

2 a (Max)

Power input of the I/O port DC24V (+ / - 20%)

Output current of the I/O
port

10 a (Max)

Power consumption 205mA

Conventional parameters

System side electrical
isolation

AC500V

Protection against reverse
connection

support

Over current protection
This function is supported by the system, but not by the

I/O

Over voltage protection support

Wire specifications 0.2 ~ 1.5 mm squared

Connection mode No screw

Overall dimensions 90 x 67 x 34 mm

The weight of the 240g

Protection grade IP20

Temperature range
Operating temperature: -10 ~ 55℃, storage temperature:

-20 ~ 85℃
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Relative humidity 95% no condensation

2.1.7 CANopen Adapter

 CANopen adapter model and order number

model Specifications describe The order no.

EX-1010 DeviceNet adapter module 02-01-01

EX-1130 Modbus TCP bus adapter 02-01-11

EX-1030 Modbus RTU adapter module 02-01-03

EX-1100 EtherCAT adapter module 02-01-04

EX-1110 PROFINET adapter module 02-01-05

EX-1040 Cc-link adapter module 02-01-06

EX-1050 CANopen adapter module 02-01-11

EX-1120 EtherNet/IP adapter 02-01-08

EX-1121 EtherNet/IP adapter 02-01-08-1

EX-1140 CC-Link IEFB bus adapter 02-01-09

 CANopen adapter parameters

Technical parameters

Bus protocol CANopen

Address set 0 ~ 99

Expanding the number of I/
OS

32

Maximum input/output
bytes

Input: 512 Byte/Output: 512 Byte

The bus rate 10 KBPS ~ 1 MBPS

Transmission distance 1000 m (Max)

System side power input DC24V (18 to 36)
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The system side provides
current

2 a (Max)

Power input of the I/O port DC24V (+ / - 20%)

Output current of the I/O
port

10 a (Max)

System power current
consumption

126mA

Conventional parameters

System side electrical
isolation

AC500V

Protection against reverse
connection

support

Over current protection
This function is supported by the system, but not by the

I/O

Over voltage protection support

Wire specifications 0.2 ~ 1.5 mm squared

Connection mode No screw

Overall dimensions 90 x 67 x 34 mm

The weight of the 240g

Protection grade IP20

Temperature range
Operating temperature: -10 ~ 55℃, storage temperature:

-20 ~ 85℃

Relative humidity 95% no condensation

2.1.8 EtherNet/IPAdapter (EX-1120)

 EtherNet/IP adapter model and order number

Model Specifications description The order no.

EX-1010 DeviceNet adapter module 02-01-01

EX-1130 Modbus TCP bus adapter 02-01-11
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EX-1030 Modbus RTU adapter module 02-01-03

EX-1100 EtherCAT adapter module 02-01-04

EX-1110 PROFINET adapter module 02-01-05

EX-1040 Cc-link adapter module 02-01-06

EX-1050 CANopen adapter module 02-01-11

EX-1120 EtherNet/IP adapter module 02-01-08

EX-1121 EtherNet/IP adapter 02-01-08-1

EX-1140 CC-Link IEFB bus adapter 02-01-09

 EtherNet/IP adapter indicator definition

Serial

number

Indicator Instructions Color State Meaning

1 SYS System indicator green

Blinking at 1Hz Communication is normal

Blinking at 5HZ
The I/O slave station lost or detected the

factory restore button signal

on The factory Settings are restored

2 UNIT PWR
System power

indicator
green

on The system power supply is normal

out
The system power supply is not

connected or faulty

3 IO PWR IO power indicator green

on The I/O power supply is normal

out
The I/O power supply is not connected or

faulty

4 MS
Module status

indicator

Green light on
Device operation: Communication is

normal

Green light flash

(1HZ)

Standby state:

Module not configured

Green red green Self-test: power-on self-test status of the
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light flash (1HZ) module

Red light flash

(1HZ)

Glitch: The device detects a recoverable

glitch

Red light on
Major fault: The device has detected a

major fault error that cannot be recovered

out No power supply: No power supply

5 NS
Network status

indicator

Green light on

Connection established: The IP address is

configured and at least one CIP

connection has been established. The

master connection has not timed out.

Green light flash

(1 HZ)

Connection not established: The IP

address is configured, the CIP connection

is not established, and the master station

connection has not timed out.

Green red green

light flash

(1 HZ)

Self-test: power-on self-test status of the

module

Red light

(1 HZ)

Connection timeout: The primary

connection times out after the IP address

is configured

Red light on
Duplicate IP address: The IP address has

been used

out No power, no IP address

6 LINK/ACT1
Indicators of

Network Port 1
green

on Network connection normal

out The network is disconnected or abnormal

7 LINK/ACT2
Indicators of

network Port 2
green

on Network connection normal

out The network is disconnected or abnormal

 EtherNet/IP adapter communication interface definition

Ethernet interface Bit number signal Signal definition
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1 TX+ Positive end of data
transmission

2 TX- Negative end of
data transmission

3 RX+ Positive data
receiving end

4 -- --

5 -- --

6 RX- Data receiving
negative end

7 -- --

8 -- --

Connector
housing

PE Chassis grounding

 EtherNet/IP DIP switch definition

IPAddress
Hundred
Bits×100

IPAddress
Ten
Bits×10

IPAddress
Bits×1

IPAddress Setting

X 100 IP address hundred bits

X 10 IP address ten bits

X 1 IP address bits

Note: The default network segment of ex-1120 is 192.168.0.x. Set the DIP switch to the IP address. For
example, set the 100 toggle to 1, 10 toggle to 9, and 1 toggle to 5.

 EtherNet/IP adapter parameters

Technical parameters

Bus protocol EtherNet/IP

Address set Dip switch Settings
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Expanding the number of I/
OS

32

Maximum input/output
bytes

Input: 504 Byte/Output: 504 Byte

The bus rate 100Mbps

Transmission distance 100m (station to station distance)

System side power input DC24V (18 to 36)

The system side provides
current

2 a (Max)

Power input of the I/O port DC24V (+ / - 20%)

Output current of the I/O
port

10 a (Max)

Power consumption 413mA

Conventional parameters

System side electrical
isolation

AC500V

Protection against reverse
connection

support

Over current protection
This function is supported by the system, but not by the

I/O

Over voltage protection support

Wire specifications 0.2 ~ 1.5 mm squared

Connection mode No screw

Overall dimensions 90 x 67 x 34 mm

The weight of the 240g

Protection grade IP20

Temperature range
Operating temperature: -10 ~ 55℃, storage temperature:

-20 ~ 85℃

Relative humidity 95% no condensation
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2.1.9 EtherNet/IPAdapter (EX-1121)

 EtherNet/IP adapter model and order number

Model Specifications description The order no.

EX-1010 DeviceNet adapter module 02-01-01

EX-1130 Modbus TCP bus adapter 02-01-11

EX-1030 Modbus RTU adapter module 02-01-03

EX-1100 EtherCAT adapter module 02-01-04

EX-1110 PROFINET adapter module 02-01-05

EX-1040 Cc-link adapter module 02-01-06

EX-1050 CANopen adapter module 02-01-11

EX-1120 EtherNet/IP adapter module 02-01-08

EX-1121 EtherNet/IP adapter 02-01-08-1

EX-1140 CC-Link IEFB bus adapter 02-01-09

 EtherNet/IP adapter indicator definition

Serial

number

Indicator Instructions Color State Meaning

1 SYS System indicator green

Blinking at 1Hz Communication is normal

Blinking at 5HZ

The I/O slave station lost or

detected the factory restore button

signal

on The factory Settings are restored

2 UNIT PWR
System power

indicator
green

on The system power supply is normal

out
The system power supply is not

connected or faulty



EX Series Card I/O

Email:contact@welllinkio.com 36

3 IO PWR IO power indicator green

on The I/O power supply is normal

out
The I/O power supply is not

connected or faulty

4 MS
Module status

indicator

Green light on
Device operation: Communication

is normal

Green light flash

(1HZ)

Standby state:

Module not configured

Green red green

flash (1HZ)

Self-test: power-on self-test status

of the module

Red light flash

(1HZ)

Glitch: The device detects a

recoverable glitch

Red light on

Major fault: The device has

detected a major fault error that

cannot be recovered

out No power supply: No power supply

5 NS
Network status

indicator

Green light on

Connection established: The IP

address is configured and at least

one CIP connection has been

established. The master connection

has not timed out.

Green light flash

(1 HZ)

Connection not established: The IP

address is configured, the CIP

connection is not established, and

the master station connection has

not timed out.

Green red green

flash

(1 HZ)

Self-test: power-on self-test status

of the module

Red light

(1 HZ)

Connection timeout: The primary

connection times out after the IP

address is configured
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Red light on
Duplicate IP address: The IP

address has been used

out No power, no IP address

6 LINK/ACT1
Indicators of

Network Port 1
green

on Network connection normal

out
The network is disconnected or

abnormal

7 LINK/ACT2
Indicators of

network Port 2
green

on Network connection normal

out
The network is disconnected or

abnormal

 EtherNet/IP adapter communication interface definition

Ethernet interface A no. signal Signal definition

1

TX+ Positive end of data
transmission

2 TX- Negative end of data
transmission

3 RX+ Positive data receiving end

4 -- --

5 -- --

6 RX- Data receiving negative
end

7 -- --

8 -- --

Connector
housing

PE Chassis grounding

 EtherNet/IP DIP switch definition
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IPAddress
Hundred
Bits×100

IPAddress
Ten
Bits×10

IPAddress
Bits×1

Note:

① The IP address is assigned and the module works in BOOTPmode.

② The ex-1121 adds a button to restore factory Settings. Hold down the button for more than 2 seconds.
When the SYS indicator changes from blinking to steady on, the factory Settings are restored.

 EtherNet/IP adapter parameters

Technical parameters

Bus protocol EtherNet/IP

Address set Dip switch Settings

Expanding the number of I/
OS

32

Maximum input/output
bytes

Input: 504 Byte/Output: 504 Byte

The bus rate 100Mbps

Transmission distance 100m (station to station distance)

System side power input DC24V (18 to 36)

Dip switch definition

Three combination
dip set values

IP address setting method

0 Set through BOOTP.

001-254. Set the low 1byte of the IP address by turning the switch.

More than 255
The module status indicator (MS) is blinking red because the settings

are incorrect
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The system side provides
current

2 a (Max)

Power input of the I/O port DC24V (+ / - 20%)

Output current of the I/O
port

10 a (Max)

Power consumption 360mA

Conventional parameters

System side electrical
isolation

AC500V

Protection against reverse
connection

support

Over current protection
This function is supported by the system, but not by the

I/O

Over voltage protection support

Wire specifications 0.2 ~ 1.5 mm squared

Connection mode No screw

Overall dimensions 90 x 67 x 34 mm

The weight of the 240g

Protection grade IP20

Temperature range
Operating temperature: -10 ~ 55℃, storage temperature:

-20 ~ 85℃

Relative humidity 95% no condensation

2.1.10 CC-link IEFB Adapter

 CC-link IEFB adapter model and order number

Model Specifications description The order no.

EX-1010 DeviceNet adapter module 02-01-01
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EX-1130 Modbus TCP bus adapter 02-01-11

EX-1030 Modbus RTU adapter module 02-01-03

EX-1100 EtherCAT adapter module 02-01-04

EX-1110 PROFINET adapter module 02-01-05

EX-1040 Cc-link adapter module 02-01-06

EX-1050 CANopen adapter module 02-01-11

EX-1120 EtherNet/IP adapter module 02-01-08

EX-1121 EtherNet/IP adapter 02-01-08-1

EX-1140 CC-Link IEFB bus adapter 02-01-09

 CC-link IEFB adapter indicator definition

serial number indicator light illustrate color state meaning

red

destroy Non-maintenance status

Flashing (5Hz)

Flashing and recovery during

upgrade transfer process

Factory testing constants

SYS

System instructions Flashing (1Hz) System is running normally

1

lamp Flashing (5Hz)

The slave station is lost or the

reset button is pressed

green

Down

Bright Factory reset completed
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Two flashes and one out Diagnostic configuration failed

UNIT PWR

System power
pointer

green Bright
The system side power supply is
normalindicator light

destroy
The system side is not powered on or
the power supply is

abn
orm
al.

IO PWR

IO power
indicator

green

Bright The IO side power supply is normal

lamp destroy
The IO side is not powered or the
power supply is abnormal.

NET-RUN Running lights green

Bright The device is running normally

destroy There is an error in the module

Bright
Module abnormality, such as duplication
of slave stations, etc.

NET-ERR

System failure
means

red destroy
Device is operating normally or is not
receiving powerindicator light

Flashing (1Hz)

IP DIP switch is abnormal for you,
DIP

Value exceeds 254

LINK/ACT1

destroy The network is not connected properly

2
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Ethernet port

Network connection is OK, but no
data

LINK/ACT2
orange
color Bright interaction

flashing

The network connection is normal and
data is transferred

mutually beneficial

serial
number

IP address dialing
instructions symbol Function

×100 Hundreds digit of IP address (valid range 0~2)

3 ×10 Ten digits of IP address (valid range 0~9)

×1 IP address single digit dialing (valid range 0~9)

4 power port

IO module input power supply (2L+, 2M)

Adapter input power (1L+, 1M)

 CC-link IEFB adapter parameters

Basic parameters
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Dimensions 90mm×67mm×14mm

Operating temperature 0〜55℃

storage temperature - 20〜85℃

Relative humidity 95% non-condensation

Protection level IP20

Wiring specifications 0.2〜1.5mm²

Wiring No screws

Power parameters

System side power input DC24V (18~36V)

System side provides current 2A（Max）

IO port side power input DC24V (±20%)

IO port side output current 10A(Max)

System test electrical isolation AC500V

Anti-reverse connection
protection support

Overvoltage protection support

Overcurrent protection
The system test supports it, but the IO side does not support

it.

Software parameters

bus protocol CC-Link IE Field Basic

Communication rate 100Mbps

Transmission distance 500m (distance between stations)

RX 64 points (occupies 1 station)
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128 points (occupies 2 stations)
192 points (occupies 3 stations)
256 points (occupies 4 stations)

RY

64 points (occupies 1 station)
128 points (occupies 2 stations)

Maximum number of link points
192 points (occupies 3 stations)

256 points (occupies 4 stations)

RW

32 points (occupies 1 station)
64 points (occupies 2 stations)
96 points (occupies 3 stations)
128 points (occupies 4 stations)

wx
32 points (occupies 1 station)
64 points (occupies 2 stations)

96 points (occupies 3 stations)
128 points (occupies 4 stations)

2.2 Digital module

Digital module is divided into input and output two modules, according to the signal type is divided into
transistor and relay, transistor can be divided into NPN and PNP two kinds, according to the point can be divided
into 8, 16, 32 input/output points.

2.2.1 Digital input module

Digital input module includes PNP and NPN two signal types and 8 point, 16 point, 32 point three input
specifications, users can choose the appropriate model according to the actual demand.The input effective level
is divided into high level signal (PNP) and low level signal (NPN).

 Product Model Information

Model Specifications description The order no.

EX-2008 8 digital input, input signal is low level NPN 02-02-01

EX-2108 8 digital input, input signal is high level PNP 02-02-02

EX-200H 16 digital input, input signal is low level NPN 02-02-03

EX-210H 16 digital input, input signal is high level PNP 02-02-04
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EX-213S 32 digital input, input signal PNP 02-02-18

EX-203S 32 digital input, input signal NPN 02-02-17

EX-2018
8 digital input, input signal is low level NPN, support 2/3 Wire

sensor
02-02-06

EX-2118
8 digital input, input signal is low level PNP, support 2/3

Wire sensor
02-02-07

EX-202H 16 02-02-08

EX-212H 02-02-09

 Module indicator

Channel indicator Color State definition

green
Normally on The module has signal input

Out The module has no signal input

 Module Parameters

Technical parameters

model EX-2008 EX-2108 EX-200H EX-210H EX-213S EX-203S EX-2018 EX-2118

The product
name Digital quantity input module

Signal types NPN PNP NPN PNP PNP NPN NPN PNP

Power
consumption 24mA 24mA 25mA 25mA 14mA 13mA 17mA 12mA

The input features

Input channel
number 8 16 32 8

Input rated
voltage 0V 24V 0V 24V 24V 0V 0V 24V

Time to
shake The value ranges from 1 to 10ms. Default value: 3ms

Isolation of
pressure AC500V
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2.2.2Digital output module

The output signal of the digital quantity output module is divided into transistor and relay. The effective
level of the output of the transistor type is divided into high level signal (PNP) and low level signal
(NPN).Digital output module has 8 point, 16 point, 32 point three types of specifications to choose from.

 Product Model Information

Model Specifications description The order no.

EX-3008 8-channel digital output, low level (NPN) 02-03-01

EX-3108 8 channels digital output, high level (PNP) 02-03-02

EX-300H 16 channels digital output, output signal is low level (NPN) 02-03-03

EX-310H 16 channels digital output, output signal is high level (PNP) 02-03-04

EX-3208 8-way relay output, output signal is relay (normally open) 02-03-05

EX-303S 32 channels digital output, output signal is low level (NPN) 02-03-18

EX-313S 32 channels digital output, output signal is high level (PNP) 02-03-19

 Module indicator

Isolation
method Optical coupling isolation

Physical parameters

The
dimensions 90 mm x 67 mm x 14 mm

Working
temperature 0 ~ 55 ℃

Storage
temperature - 20 ~ 85 ℃

Relative
humidity 95% no condensation

Protection
grade IP20
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Channel indicator Color state define

green
Normally on The module has signal output

Out The module has no signal output

 Module Parameters

Technical parameters

model EX-3008 EX-3108 EX-300H EX-310H EX-3208 EX-303S EX-313S

The product
name Digital output module

Signal types NPN PNP NPN PNP relay NPN PNP

Current
consumption 50mA 50mA 72mA 72mA 45mA 18mA 19mA

Output characteristic

Output channel
number 8 8 16 16 8 32 32

Power
consumption 0V 24V 0V 24V - 0V 24V

The drive ability
Single channel load 500mA, each

continuous 8 channels maximum total
current 2A

0.5 A, 2
A,

DC30V/A
C125V

Single channel load
500mA, each
continuous 8

channels maximum
total current 2A

The load type Resistive load, inductive load, lamp load

Over current
protection support

Overheating
protection support

Isolation of
pressure AC500V

Isolation method Optical coupling isolation

Physical parameters

The dimensions 90 mm x 67 mm x 14 mm
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Working
temperature 0 ~ 55 ℃

Storage
temperature - 20 ~ + 85 ℃

Relative
humidity 95% no condensation

Protection grade IP20

2.3 Analog module

Analog module is divided into input and output modules, voltage type and current type according to signal
type, 12-bit and 16-bit according to resolution, and 4-channel and 8-channel according to channel.

2.3.1Analog input module

Analog input module is divided into voltage type and current type.Voltage input module has 4 ranges to
choose from, respectively 0 ~ 10V, ±10V, 0 ~ 5V, ±5V;Current input module is 4 ~ 20mA, 0 ~ 20mA, analog
input module resolution is 12bit (accuracy 0.1%) and 16bit (accuracy 0.02%).

 Product Model Information

Model Specifications description The order no.

EX-4014

4 channel voltage input, resolution 12bit, accuracy 0.1%,

The range is 0 ~ 10V
02-04-01

4 channel voltage input, resolution 12bit, accuracy 0.1%,

The range is 0 ~ 5V
02-04-02

EX-4114

4 channel voltage input, resolution 12bit, accuracy 0.1%,

Range ±10V
02-04-03

4 channel voltage input, resolution 12bit, accuracy 0.1%,

Measuring range ±5V
02-04-04

EX-4054

4 channel voltage input, resolution 16bit, accuracy 0.02%,

Range 0-10V
02-04-05

4 channel voltage input, resolution 16bit, accuracy 0.02%,

Range 0-5V
02-04-06

EX-4154 4 channel voltage input, resolution 16bit, accuracy 0.02%, 02-04-07
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 Module indicator

Channel indicator Color state Definition

green Flash There is analog signal input

Range ±10V

4 channel voltage input, resolution 16bit, accuracy 0.02%,

Measuring range ±5V
02-04-08

EX-4414

4 channel current input, resolution 12bit, accuracy 0.1%,

The range is 4 ~ 20mA
02-04-09

4 channel current input, resolution 12bit, accuracy 0.1%,

The range is 0 ~ 20mA
02-04-10

EX-4454

4 channel current input, resolution 16bit, accuracy 0.02%,

The range is 4 ~ 20mA
02-04-11

4 channel current input, resolution 16bit, accuracy 0.02%,

The range is 0 ~ 20mA
02-04-12

EX-4018

8 channel voltage input, resolution 12bit, accuracy 0.1%,

The range is 0 ~ 10V
02-04-29

8 channel voltage input, resolution 12bit, accuracy 0.1%,

The range is 0 ~ 5V
02-04-30

EX-4118

8 channel voltage input, resolution 12bit, accuracy 0.1%,

Range ±10V
02-04-31

8 channel voltage input, resolution 12bit, accuracy 0.1%,

Measuring range ±5V
02-04-32

EX-4418

8 channel current input, resolution 12bit, accuracy 0.1%,

The range is 4 ~ 20mA
02-04-33

8 channel current input, resolution 12bit, accuracy 0.1%,

The range is 0 ~ 20mA
02-04-34
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Normally on Analog input is out of range

Out No analog signal input

The following table is the corresponding numerical table of analog input range. The blue line in the broken line
diagram is voltage type, and the orange line is current type

 Analog quantity range corresponds to the value

Input type

Resolution Polarity

Simulated Quantity Input Value

Voltage-mode Current-mode

Unipolar

bipolar

Unipolar

bipolar

12 bit

16 bit

 Analog voltage input module digital - analog curve

12-bit voltage type unipolar input module range

12-bit voltage type bipolar input module range
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 Analog current mode input module digital - analog curve

12-bit current type input module range

 12-bit 4-20mA analogical conversion formula (X is current value, Y is the corresponding
value of current value) :

� − 4
20 − 4 =

�
4095

 12-bit 0-20mA analogical conversion formula (X is the current value, Y is the corresponding
value of the current value) :

X
20

=
Y

4095

 12-bit 0-10V digital-analog conversion formula (X is the voltage value, Y is the
corresponding value of the current voltage value) :

X
10

=
Y

4095

 16-bit 0-10V digital-analog conversion formula (X is the voltage value, Y is the
corresponding value of the current voltage value) :

X
10

=
Y

65535

 Module Parameters

Technical parameters

model EX-4014 EX-4018 EX-4114 EX-418 EX-4054 EX-4154 EX-4414 EX-4454 EX-4418

The product Analog input module
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name

Signal types 0 to 10V,0 to 5V Plus or minus 10 v,
+ 5 v

0 ~ 10 v

0 ~ 5 v

Plus or
minus 10

v

+ 5 v

4 ~ 20mA,0 ~ 20mA

Power
consumption 82mA 82mA 82mA 182mA 82mA 82mA 53mA 182mA 182mA

The input features

Output channel
number 4 8 4 8 4 4 4 4 8

The input filter Configurable: level 0 to 3 (default 1)

The input
impedance > 500 k Ω 100 Ω

The resolution
of the 12 16 12 16 12

precision 0.1% 0.02% 0.1% 0.02% 0.1%

Over voltage
protection support

Isolation of
pressure AC500V on the field side and digital side, channels are not isolated

Physical parameters

The dimensions 90 mm x 67 mm x 14 mm

Working
temperature 0 ~ 55 ℃

Protection
grade IP20

2.3.2 Analog output module

Analog output module is divided into voltage type and current type.Voltage input module has
4 ranges to choose from, respectively 0 ~ 10, ±10V, 0 ~ 5V, ±5V;Current input module is divided
into 4 ~ 20mA, 0 ~ 20mA.Analog output module resolution is 12bit (accuracy 0.1%) and 16bit
(accuracy 0.02%).

 Product Model Information

model Specifications description The order no.
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EX-5014

4 channel voltage output, resolution 12bit, accuracy 0.1%,

The range is 0 ~ 10V
02-05-01

4 channel voltage output, resolution 12bit, accuracy 0.1%,

The range is 0 ~ 5V
02-05-02

EX-5114

4 channel voltage output, resolution 12bit, accuracy 0.1%,

Range ±10V
02-05-03

4 channel voltage output, resolution 12bit, accuracy 0.1%,
measuring range ±5V

02-05-04

EX-5054

4 channel voltage output, resolution 16bit, accuracy 0.02%,

The range is 0 ~ 10V
02-05-05

4 channel voltage output, resolution 16bit, accuracy 0.02%,

The range is 0 ~ 5V
02-05-06

EX-5154

4 channel voltage output, resolution 16bit, accuracy 0.02%,

Range ±10V
02-05-07

4 channel voltage output, resolution 16bit, accuracy 0.02%,

Measuring range ±5V
02-05-08

EX-5414

4 channel current output, resolution 12bit, accuracy 0.1%,

The range is 4 ~ 20mA
02-05-09

4 channel current output, resolution 12bit, accuracy 0.1%,

The range is 0 ~ 20mA
02-05-10

EX-5454

4 channel current output, resolution 16bit, accuracy 0.02%,

The range is 4 ~ 20mA
02-05-11

4 channel current output, resolution 16bit, accuracy 0.02%,

The range is 0 ~ 20mA
02-05-12

EX-5018

8 channel voltage output, resolution 12bit, accuracy 0.1%,

The range is 0 ~ 10V
02-05-13

8 channel voltage output, resolution 12bit, accuracy 0.1%, 02-05-14
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The range is 0 ~ 5V

EX-5118

8 channel voltage output, resolution 12bit, accuracy 0.1%,

Range ±10V
02-05-15

8 channel voltage output, resolution 12bit, accuracy 0.1%,

Measuring range ±5V
02-05-16

EX-5418

8 channel current output, resolution 12bit, accuracy 0.1%,

The range is 4 ~ 20mA
02-05-17

8 channel current output, resolution 12bit, accuracy 0.1%,

The range is 0 ~ 20mA
02-05-18

 Module indicator

Channel indicator Color State definition

green

Flash There is analog signal output

Normally on Program channel value out of range

Out No analog signal output

The following table is the corresponding numerical table of analog input range. The blue line in
the broken line diagram is voltage type, and the orange line is current type

 Analog quantity range corresponds to the value

Input type

Resolution Polarity

Simulated Quantity Input Value

Voltage-mode Current-mode

Unipolar

bipolar

Unipolar

bipolar

12 bit

16 bit

 Analog voltage output module modulus curve

12-bit voltage type unipolar input module range
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12-bit voltage type bipolar input module range

 Analog voltage output module modulus curve

12-bit current type input module range

 12-digit 4-20mAmodulus conversion formula (X is the current value, Y is the corresponding
value of the current value) :
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� − 4
20 − 4

=
�

4095

 12-bit 0-20mAmodulus conversion formula (X is the current value, Y is the corresponding
value of the current value) :

X
20

=
Y

4095

 12-bit 0-10V modulus conversion formula (X is the voltage value, Y is the corresponding
value of the current voltage value) :

X
10

=
Y

4095

 16-bit 0-10V modulus conversion formula (X is the voltage value, Y is the corresponding
value of the current voltage value) :

X
10

=
Y

65535

 Module Parameters

Technical parameters

model EX-5014 EX-5018 EX-5114 EX-5118 EX-5054 EX-5154 EX-5414 EX-5454 EX-5418

The product
name Analog output module

Signal types 0 to 10V,0 to 5V Plus or minus 10 v,
+ 5 v

0 ~ 10 v

0 ~ 5 v

Plus or
minus 10

v

+ 5 v

4 ~ 20mA,0 ~ 20mA

Power
consumption 24mA 21mA 24mA 21mA 24mA 24mA 21mA 21mA 21mA

The input features

Output channel
number 4 8 4 8 4 4 4 4 8

The output load > 10 k Ω < 500 Ω

The load type Impedance load

The resolution
of the 12 16 12 16 12

precision 0.1% 0.02% 0.1% 0.02% 0.1%
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Over voltage
protection support

Isolation of
pressure AC500V on the field side and digital side, channels are not isolated

Physical parameters

The dimensions 90 mm x 67 mm x 14 mm

Working
temperature 0 ~ 55 ℃

Protection
grade IP20

2.4 Temperature Collection module

The temperature collection module is divided into thermocouple (TC) and thermal resistance
(RTD) according to the sensor type.

2.4.1 Thermocouple module

The filter of each channel of the thermocouple temperature collection module can be
configured separately (default is 10). The thermocouple temperature collection module can support
10 types of thermocouple sensors, which are K, J, T, E, N, S, R, B, C, and MV.

 Product Model Information

model Specifications description The order no.

EX-46
54

4 channel K thermocouple acquisition module,

Range of -100 ~ 1370℃
02-04-13

4 channel J thermocouple acquisition module,

Range -100 ~ 1200℃
02-04-14

4 channel T thermocouple acquisition module,

Range -100 ~ 400℃
02-04-15

4 channel TYPE E thermocouple acquisition
module,

Range -100 ~ 1000℃
02-04-16
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4-channel N-type thermocouple acquisition
module,

Range -100 ~ 1300℃
02-04-17

4-channel S-type thermocouple acquisition
module,

Range 0 ~ 1700℃
02-04-18

4 channel R thermocouple acquisition module,

Range 0 ~ 1700℃
02-04-19

4 channel B thermocouple acquisition module,

The range is 600 ~ 1800℃
02-04-20

4 channel C thermocouple acquisition module,

Range 0 ~ 2320℃
02-04-21

4 channel MV voltage signal acquisition module,

Range -100mv to 100mv
02-04-22

 Module indicator

Channel indicator
Color

state definition

green

Flash Thermocouple sensor has signal input

Normally on
Thermocouple sensor signal out of

range

Out No thermocouple sensor signal input

 Table of values corresponding to temperature values measured in EX-4654

EX-4654

Type Temperature(℃) Numerical (decimal) Bolt value Note

K -100〜+1370 -1000〜+13700 32767

The code value obtained by PLC is
divided by 10 to obtain the actual

temperature value
J -100〜+1200 -1000〜+12000 32767

T -100〜+400 -1000〜+4000 32767
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E -100〜+1000 -1000〜+10000 32767

N -100〜+1300 -1000〜+13000 32767

S 0〜+1700 0〜+17000 32767

R 0〜+1700 0〜+17000 32767

B 600〜+1800 6000〜+18000 32767

C 0〜+2320 0〜+23200 32767

mv -100〜+100mv -30000〜30000 32767
The actual -100 mv to +100 mV is
mapped to the range of -30000 to

30000

 Module Parameters

Technical parameters

model EX-4654

Product name Thermocouple module

Power
consumption 41mA

The input features

Input channel
number 4

The input filter The value ranges from 0 to 40. Default value: 10

The connection
method 2 wire system

Signal types
K, J, T, E, N, S

R, B, C, mV

Temperature
range Default: TYPE K: -100...+ 1370 ℃

The resolution of
the 0.1 ℃ / digital

precision 0.5% (full scale)
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Over voltage
protection support

Isolation of
pressure

AC500V on the field side and digital side, channels are
not isolated

Diagnosis and Alarm

Disconnect the
alarm

Supported (When the channel code value is 32767, the
channel is disconnected)

Physical parameters

The dimensions 90 mm x 67 mm x 14 mm

Working
temperature 0 ~ 55 ℃

Storage
temperature - 20 ~ + 85 ℃

Relative
humidity 95% no condensation

Protection grade IP20

2.4.2 Thermal Resistance Module

The filter of each channel of the thermal resistance temperature acquisition module can be
configured separately (the default is 10). The thermal resistance temperature acquisition module
can support six types of thermal resistance sensors, namely PT100, PT200, PT500, PT1000, Ni120,
and resistance measurement.

 Product Model Information

model Specifications describe
The order
no.

EX-47
54

4 channel PT100 thermal resistance acquisition
module,

Range -200 ~ 800℃

02-04-23

4 channel PT200 thermal resistance acquisition
module,

Range of -200 ~ 630℃

02-04-24

4 channel PT500 thermal resistance acquisition 02-04-25
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module,

Range of -200 ~ 630℃

4 channel PT1000 thermal resistance
acquisition module,

Range -50 ~ 300℃

02-04-26

4 channel Ni120 thermal resistance acquisition
module,

Range -79 ~ 309℃
02-04-27

4-channel resistance value acquisition module,

The range is 0 ~ 400 ω
02-05-28

 Module indicator

Channel indicator
Color

state definition

green

flashing
The thermal resistance

sensor has signal input

Normally on
Signal of thermal resistance
sensor is out of range

destroy
No thermal resistance
sensor signal input

 Table of values corresponding to temperature values measured in EX-4754

EX-4754

Type Temperature(℃) Numerical value
(decimal) Bolt value Note

PT100 -200〜+800 -2000〜+8000 32767 The code value obtained by PLC is
divided by 10 to obtain the actual

temperature value
PT200 -200〜+630 -2000〜+6300 32767

PT1000 -50〜+300 -500〜+3000 32767

NI120 -79〜+309 -790〜+3090 32767

Resistance
measurement 0 〜2000Q 0〜30000 32767 Map the actual 0~2000 equal scale to

the range 0~30000
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 Module Parameters

Technical parameters

model EX-4754

The product
name Thermal resistance module

Power
consumption 38mA

The input features

Input channel
number 4

The input filter The value ranges from 0 to 40. Default value: 10

The connection
method 2-wire or 3-wire (default 3-wire)

Signal types PT100/PT200/PT500/PT1000/Ni20

Temperature
range - 200...+800 degrees (PT sensor), -79...+309 degrees (Ni sensor)

The resolution of
the 0.1 ℃ / digital

precision + / - 1 ℃

Over voltage
protection support

Isolation of
pressure

AC500V on the field side and digital side, channels are not isolated

Diagnosis and Alarm

Disconnect the
alarm

Supported (When the channel code value is 32767, the channel is
disconnected)

Physical parameters

The dimensions 90 mm x 67 mm x 14 mm

Working
temperature 0 ~ 55 ℃

Storage - 20 ~ + 85 ℃
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temperature

Relative
humidity 95% no condensation

Protection grade IP20

2.5 Function Modules

Function module is divided into encoder module and high-speed pulse output module,
according to the input/output signal type into NPN, PNP, differential.

2.5.1 Encoder Module

The encoder module can be divided into NPN, PNP and differential according to the input
signal type, supporting encoder 1, 2 and 4 multiplier.

 Product Model Information

model Specifications description
The order
no.

EX-60
01 1 channel NPN, maximum input frequency 1MHz, 02-06-01

EX-60
11

1 channel PNP, maximum input frequency 1MHz, 02-06-02

EX-60
21

1 channel differential, maximum input frequency
1MHz,

02-06-03

 Module Parameters

Technical parameters

model EX-60
01 EX-6011 EX-6021

The product name Encoder module

Power consumption 38mA 38mA 75mA

The input features

Input channel
number 1 channel

Input signal type NPN PNP The differential
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Counting mode Linear, ring counter form

Count range 0 to 4294967295 or -2147483648 to 2147483648

Counting function
selection

Count disable, latch counter, sampling counter, cycle
pulse counter

Frequency, rotation speed, period measurement

Maximum input
frequency 1MHz

Orthogonal encoder
multiplier ×1, ×2, ×4

The input
impedance > 5 k Ω

Electrical isolation Optical coupling isolation

Maximum
connection distance of

signal cables
2m 2m 10m

Physical parameters

The dimensions 90 mm x 67 mm x 14 mm

Working
temperature 0 ~ 55 ℃

Protection grade IP20

2.6 Communication Module

Communication modules are classified into RS485 communication modules, RS232 and
RS485 communication modules.

2.6.1 Communication module

 Product Model Information

model Specifications description
The order
no.

EX-63
01

RS485 free port communication module, supporting
master/slave mode (default master station)

02-06-10

EX-63 RS232 Free port communication module, supporting 02-06-11
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11 master/slave mode (default master station)

EX-63
21

Modbus RTU Master communication module 02-06-14

 Module parameters

Technical parameters

model EX-6301 EX-6311 EX-6321

The product
name

RS485
communication

module

RS232
communication module

Modbus RTU
Master

Current
consumption 195mA

The input features

Input channel 1

Baud rate Optional: 1200, 2400, 4800, 9600 (default), 19200, 38400,
57600, 115200kbps

Data bits 5, 6, 7, 8 bits (default) eight

Check digit None (default), Odd, Even

Stop bit 1 (default), 2 stop bits

Automatic
timing sending

function

Time interval optional: 50ms,
100ms, 200ms, 400ms, 500ms, 600ms,
800ms, 1S (default), 1.5s, 2S, 3S, 4S, 5s,

6s,

8 s, 10 s

Does not support

A master-slave
mode Yes, default master mode Only the primary

site is supported

Response
timeout

After the primary
site sends a command, it
waits for the response
time of the secondary
site. The value ranges
from 1 to 65535 (1000

ms by default)

Character space
Frame character

interval detection time
(the time for transmitting



EX Series Card I/O

Email:contact@welllinkio.com 66

a single character,
depending on baud rate)
(default: 5 characters)

Physical parameters

The dimensions 90 mm x 67 mm x 14 mm

Working
temperature 0-55 ℃

Storage
temperature - 20 ~ + 85 ℃

Relative
humidity 95% no condensation

Protection
grade IP20

2.7 Auxiliary Modules

Auxiliary modules are divided into power module and terminal module.A of psus, which respectively
provide extra load for I/O modules, You can configure the psus as required under specific conditions.

2.7.1 Power Module and Terminal Module

 Product Model Information

model Specifications description The order no.

EX-TER01 Terminal module 02-00-00

EX-0100

System power I/O and power module, side power supply
voltage DC24V to voltage DC5V±5%, maximum output load
2A, used for adapter and IO module processor power supply,

which can provide IO power for 10A.

02-00-01

 Module Parameters

Technical parameters

model EX-0100

The product
name System power supply and I/O power module

Power supply features
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System side power
supply voltage DC24V (18 to 36 v)

Output system
voltage 5 v (+ / - 5%)

Output system
current

2 a (Max)

DC24V (18 to 36 v)

10 a (Max)

Power supply
voltage of the I/O

side

Load current on the
I/O side

Over voltage
protection support

Protection against
reverse connection support

Physical parameters

The dimensions 90 mm x 67 mm x 14 mm

Working
temperature 0-55 ℃

Storage temperature - 20 ~ + 85 ℃

Relative
humidity 95% no condensation

Protection grade IP20

3 Module Installation

3.1 Basic Knowledge

All EX system modules are open equipment, which means that EX system I/O modules can
only be installed in the connection, control cabinet or electrical operating room, and dry
environment (protection class IP20).Provide safety protection in cabinets, control cabinets or
operating rooms to prevent electric shock and the spread of fire.

EX series I/O modules can be installed on mounting rails that comply with EN 60715 (35 x
7.5 mm or 35 x 15 mm).In the control cabinet, the installation guide rail needs to be separately
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grounded.Exception: If the guide rail is mounted on a grounded galvanized mounting plate, it is
not necessary to ground the guide separately.

3.2 Installation Clearance

When installing or removing an EX distributed I/O system, keep a minimum clearance, as shown
in Figure 3-1.

Figure 3-1 Minimum installation clearance

3.3 INSTALLING I/O Modules

3.3.1 Installing the Entire Module Group

Secure the installed modules to the guide rails, as shown in Figure 3-2.

1 Loosen guide rail buckles on all modules.

2 The module is hooked on the installation guide rail.

3 The module is fixed on the guide rail.

4 Module guide rail latch is locked.



EX Series Card I/O

Email:contact@welllinkio.com 69

Figure 3-2 Installing an entire module group

3.3.2 Adding an I/O Module

Figure 3-3 shows the sequence of adding an I/O module to the INSTALLED I/O system.

1 Loosen the buckle of the module guide rail.

2 Hook the module on the mounting guide rail.

3 The module is fixed on the guide rail.

4 Shift the module to the left from the guide rail.

5 Latch the module guide rail.
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Figure 3-3 Adding an I/O module

3.4 Wiring standards and connecting standards

The diameter of the cable to be connected is 0.2-1.5, and the stripping length is 9-10mm. It is
recommended to use a tubular cord end terminal.

Figure 3-4 shows the system line standard.

Figure 3-4 wring standards

W terminal
diameter

L/F Length of
the terminal

D tube
diameter

Gb/mm
squared

Stripping
length /mm

2.8 3.0 (2.8) 16.4/10 1.3 1.5 (1.3)
0.75 1.5
(0.75)

10 mm + / -
4

The proposed dimensions are in front of the brackets, and the standard dimensions are in the brackets.
The dimensions of W, F and D are in mm

Use standard crimping pliers to crimp cables, as shown in Figure 3-5

Figure 3-5 Cable crimping mode
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4 Module size diagram and wiring diagram

4.1 Module size diagram

Module dimensions can be classified into adapter, IO module, and terminal module dimensions.

4.1.1 Adapter size diagram

Figure 4-1 shows the dimensions (length, width, height) of all adapter modules in the EX series.

Figure 4-1 Dimensions of the adapter module

4.1.2 I/O Module Dimensions diagram

Figure 4-2 shows the dimensions of the 32-channel I/O module. Figure 4-3 shows the
dimensions of the other I/O modules.

Figure 4-2 Dimensions of the digital 32 channel INPUT/output module
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Figure 4-3 DIMENSIONS of the I/O module

4.1.3 Terminal module size diagram

Figure 4-4 Dimensions of a terminal module
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4.2 Module Wiring diagram

4.2.1 Adapter wiring diagram

All adapters in the EX series are connected to the same cable. The cable connections to the
adapter are divided into system power and I/O power. Figure 4-5 shows the cable connections.

Figure 4-5 Adapter wiring diagram

Note: EX series adapter power supply is divided into system power supply and I/O power supply. To
avoid interference to the system, you are advised to connect two sets of power cables from the same
DC24V power module to the system power supply and I/O power supply respectively.

4.2.2 Wiring diagram of digital input module

EX series digital quantity input module, EX-2008 /EX-200H input signal is NPN,
EX-2108/EX-210H input signal is PNP, EX-203S input signal support NPN and PNP.

 Figure 4-6 shows the wiring diagram of the EX-2008/EX-200H/EX-2108/EX-210H module.
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4.2.3 Wiring diagram of digital output module

EX series digital quantity output module, EX-3008 /EX-300H/EX-303S output signal is NPN,
EX-3108/EX-310H/EX-313S output signal is PNP, EX-3208 is relay output module.

 Figure 4-9 shows the wiring diagram of the EX-3008/EX-300H/EX-3108/EX-310H module.

 Figure 4-10 shows the ex-3208 module wiring diagram.

Figure 4-9 EX-3008 /EX-300H/EX-3108/EX-310H module wiring diagram
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Figure 4-10 Wiring diagram of the EX-3208 relay output module

4.2.4 Analog input module wiring diagram

The analog input module is divided into voltage and current according to the input signal
type. The voltage or current type connection mode is two-wire system.

Hint: Enter 2/3/4 and refer to 6.1.8

 Figure 4-11 shows the module wiring diagram for EX-4014, EX-4114, EX-4054, EX-4154,
EX-4018, and EX-4118.

 Figure 4-12shows the wiring diagram for the EX-4414/EX-4454/EX-4418 module.

Figure 4-11 Wiring diagram of voltage input signals Figure 4-12 Wiring diagram of
current input signals

For three-wire/four-wire connection, please refer to 6.1.8
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4.2.5 Analog output module wiring diagram

The analog output module is divided into voltage and current according to the output signal
type. The voltage or current type connection mode is two-wire system.

 Figure 4-13 shows the module wiring diagram of ex-5014, EX-5114, EX-5054, EX-5154,
EX-5018, and EX-5118.

 Figure 4-14 shows the wiring diagram for the EX-5414/EX-5454/EX-5418 module.

Figure 4-13 Voltage output signal wiring diagram Figure 4-14 Current type I/O
signal wiring diagram

4.2.6 Temperature Module wiring diagram

EX series products are divided into two types of temperature modules: thermocouple and
thermal resistance, with four input channels.

 Figure 4-15 shows the wiring diagram of the EX-4654 module.

 Figure 4-16 shows the wiring diagram of the EX-4754 module.
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Figure 4-15 Wiring diagram of the EX-4654 module Figure 4-16 Ex-4754 module
wiring diagram

For three-wire/four-wire connection, please refer to 6.1.8

4.2.7 Wiring diagram of Function Modules

Function module is divided into encoder module and high-speed pulse output module, according to
the signal type into differential, NPN, PNP three.

 Figure 4-17 shows the wiring diagram of the EX-6001/EX-6011 encoder (NPN/PNP) module.

 Figure 4-18 shows the wiring diagram of the EX-6021 encoder (differential) module.

NPN

encod

er

Figure 4-17 Wiring diagram of the EX-6001/EX-6011 encoder module

file:///C:/Users/一世安/Desktop/总%20德克威尔EX卡片式远程IO用户手册.docx
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Note: The longest connection line of NPN/PNP encoder shall not exceed 2m. The Latch input signal type of
EX-6001 and EX-6011 is NPN.

Differ

ential

encod

er

Figure 4-18 Wiring diagram of the ex-6021 encoder module

Note: the longest connection line of differential encoder shall not exceed 10m

Driver

4.2.8 Communication Module wiring diagram

 Figure 4-19 shows the wiring diagram of the EX-6301 module.
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 Figure 4-20 shows the wiring diagram for the EX-6311 module.

 Figure 4-21 shows the wiring diagram for the EX-6321 module.

RS485
Master/Slave

Device

Figure 4-19 Wiring diagram of the EX-6301 module

Note: The communication distance between the EX-6301 module and the RS485 master/slave device
depends on the communication medium (such as communication cable or wireless relay) or baud rate.

RS232
Master/Slave

Device

Figure 4-20 Wiring diagram of the EX-6311 module

Note: shielded cables are recommended for the communication distance between the ex-6311 module and
the RS232 master/slave device to be less than 15m.
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Figure 4-21 Wiring diagram of the EX-6321 module

4.2.9 Power Module Wiring Diagram

The ex-0100 power module needs to be connected to two sets of DC24V power cables.
1L+/1M for the system power supply and 2L+/2M for the I/O power supply. You are advised to
connect two sets of power cables from the same DC24V power module to the system power
supply and I/O power supply respectively, as shown in figure 4-22.

Figure 4-27 Power module wiring diagram
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5 EX Remote I/O configuration

This chapter mainly introduces the EX series remote IO adapter with IO module and the
current industrial mainstream PLC configuration.

5.1 Connection between Ex-1100 and PLC

5.1.1 Connection and Configuration between TwinCAT2 and EX-1100

1. Communication connection diagram, as shown in Figure 5-1-1.

Programming computer

Adapter

Figure 5-1-1 communication connection diagram

2. Table 5-1-1 shows the hardware configuration

Table 5-1-1 Hardware configuration table

Hardware Quantity Note

Computer programming 1 Install TwinCAT2
EX-1100 1 EtherCAT adapter
EX-210H 1 Digital input
EX-3108 1 Digital output module
EX-4014 1 Analog input module
EX-5014 1 Analog output module

Ethernet cable A number of

3. Install the XML description file

Install the XML description file into TwinCAT2, as shown in Figure 5-1-2.(TwinCAT2
default path: C: TwinCAT\Io\EtherCAT)
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Figure 5-1-2 Installing the XML description file

4. New project and equipment configuration

Click the TwinCAT icon at the lower right corner of the computer and select "System
Manager" to open TwinCAT software, as shown in Figure 5-1-3.

Figure 5-1-3 Starting TwinCAT software

After the TwinCAT software is started, click I/O Devices on the left of the project and
right-click Scan Devices, as shown in Figure 5-1-4.

Figure 5-1-4 Selecting Scan Devices
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In the New I/O Devices Found window, select the network card that you want to connect to
EtherCAT I/O, as shown in Figure 5-1-5.

Figure 5-1-5 Selecting a network card

Select "Yes" in the prompt window "Scan for Boxes", and the adapter EX-1100 and the
attached I/O module are scanned, as shown in picture 5-1-6.

Figure 5-1-6 Scanning the I/O module

5. I/O monitoring and forced output

Choose Box1 (EX-1100) > Module2 (EX-3108) > Channels Date from the left pane of the
project. Double-click Channel 1 to pop up the Set Value Dialog window, and Set the mandatory
Value to 1, as shown in Figure 5-1-7.
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Figure 5-1-7 Mandatory input values

6. Variable association

Right-click PLC-Configration on the left of the project, select Add PLC project, and associate
the defined INPUT and output variables to the I/O channel, as shown in Figure 5-1-8.
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Figure 5-1-8 Correlation of variables

5.1.2 Connection and Configuration between TwinCAT3 and EX-1100

1. Communication connection diagram, as shown in Figure 5-1-9.

Programming computer

Adapter

Figure 5-1-9 Communication connection diagram

2. Table 5-1-2 shows the hardware configuration

Table 5-1-2 Hardware configuration table

Hardware Quantity Note

Computer programming 1 Install TwinCAT3
EX-1100 1 EtherCAT adapter
EX-4014 1 Analog input module
EX-5014 1 Analog output module

Ethernet cable A number of

3. Install the XML description file



EX Series Card I/O

Email:contact@welllinkio.com 86

Install the XML description file into TwinCAT3, as shown in figure 5-1-10.The example
default folder is

(C: \ TwinCAT \ \ Config \ Io \ EtherCAT 3.1)

Figure 5-1-10 Installing the XML description file

4. New project and equipment configuration

Open TwinCAT3 software and choose "File" > New > Project from the menu bar, as shown
in Figure 5-1-11. In the window of new Project, select "TwinCAT Projects", as shown in Figure
5-1-12.

Figure 5-1-11 New project

Figure 5-1-12 Selecting TwinCAT Project
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Scan the IO connected to the programming computer into the project. Click "I/O" >
"Devices" > "Scan" in the project tree, as shown in Figure 5-1-13. The hardware configuration
displayed in the Scan is shown in Figure 5-1-14.

Figure 5-1-13 Scanning I/O devices

Figure 5-1-14 Hardware configuration

5. IO monitoring and forced output

In the project tree, choose I/O > Devices > Device3 (EtherCAT) > Box1 (EX-1100) >
Mobule2 (EX-5014) > Channels Data. Double-click Channel 0. Choose Online > Write and force
the value to 1000, as shown in Figure 5-1-15. Figure 5-1-16 shows the monitoring result.
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Figure 5-1-15 Forcing write values

Figure 5-1-16 Monitoring results
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5.1.3 Connection and Configuration of CODESYS and EX-1100

1. Communication connection diagram, as shown in Figure 5-1-17.

Programming computer
Codesys v3.5

Adapter

Figure 5-1-17 Communication connection diagram

2. The hardware configuration is shown in Table 5-1-3

Table 5-1-3 Hardware configuration table

Hardware Quantity Note

Computer programming 1 Install the Codesys V3.5
EX-1100 1 EtherCAT adapter
EX-4014 1 Analog input module
EX-5014 1 Analog output module

Ethernet cable A number of

3. Install the XML description file

Open CODESYS V3.5 and choose Tools > Device Repository from the menu bar, as shown
in Figure 5-1-18.
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Figure 5-1-18 Installing the XML device description file

4. New project and equipment configuration

Open CODESYS V3.5 software and choose "New Project" > "Project" > "Standard Project",
as shown in Figure 5-1-19.
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Figure 5-1-20 New construction project

In the standard engineering window, select CODESYS SoftMotion Win V3 for device and
Structured Text (ST) for PLC_PRG programming language, as shown in Figure 5-1-21.

Figure 5-1-21 Selecting device and programming language

Note: Softmotion can bring driver and I/O, Control can only bring I/O and can not bring driver.

In the Device tree, choose Device (CODESYS SoftMotion Win V3) > Add Device, as shown
in Figure 5-1-22. In the Device adding window, choose FieldBus > EtherCAT > EtherCATMaster,
as shown in Figure 5-1-23.
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Figure 5-1-22 Adding devices

Figure 5-1-23 Selecting the EtherCAT bus

To assign a network port to EtherCATMaster, double-click "EtherCAT_Master" >
"EtherCAT NIC Settings" > "Browse" in the device tree, as shown in Figure 5-1-24.

Figure 5-1-24 Assigning network ports

Tip: Before assigning network ports, you need to download the project to the controller

Scan the actual hardware configuration into the project, right click "EtherCAT_Master" >
"Scan Device", and you can see the actual hardware configuration in the scanning window, as
shown in Figure 5-1-25.
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Figure 5-1-25 Scanning equipment

5. The program is downloaded, run and monitored. The monitoring results are shown in Figure
5-1-26.

Figure 5-1-26 Monitoring results

5.1.4 Connection and Configuration between Sysmac Studio and EX-1100

1. Communication connection diagram, as shown in Figure 5-1-27.
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Adapter

Programming computer

Figure 5-1-27 Communication connection diagram

2. Table 5-1-4 shows the hardware configuration

Table 5-1-4 Hardware configuration table

Hardware Quantity Note

Computer programming 1 Sysmac Studio
The controller 1 NJN301-1100
EX-1100 1 EtherCAT adapter

EX-210H 1 Digital quantity input
module

EX-3108 1 Digital measuring heat
output module

EX-4014 1 Analog input module
EX-5014 1 Analog output module

Ethernet cable A number of

3. Install the XML description file

Install the XML description file into Sysmac Studio, as shown in Figure 5-1-28.Example
Default folder
C:\ProgramFiles(x86)\OMRON\SysmacStudio\IODeviceProfiles\EsiFiles\UserEsiFiles)

Figure 5-1-28 Installing the XML description file

4. New project and equipment configuration
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Open Sysmac Studio, select New Project, and configure the device model and version
number, as shown in Figure 5-1-29.

Figure 5-1-29 New construction project

Add the adapter, double-click EtherCAT in the multi-view browser, select Well-Link IO in
the toolbox, and select EX-1100 Rev at the bottom of the toolbox, as shown in Figure 5-1-30.

Figure 5-1-30 Adding an adapter

In the EtherCAT view, click ex-1100 and choose edit Module Configuration, as shown in
Figure 5-1-31. I/O configuration is performed according to the actual I/O hardware configuration,
as shown in Figure 5-1-32.
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Figure 5-1-31 Edit module configuration

Figure 5-1-32 I/O configuration

Click the online icon, right-click on the icon of the master device, and select Write slave
device node address (well-link EtherCAT slave device default node is 0, so the node number must
be set), as shown in Figure 5-1-33.
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Figure 5-1-33 Node address writing

Note: After the node address is written, the device needs to be restarted for the node address to take
effect.

After the device is restarted, download the program to the controller. Choose Controller >
Transferring > Transfer to Controller (T) from the menu bar, as shown in Figure 5-32. Then
download the program, as shown in Figure 5-1-34.
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Figure 5-1-34 Program download

Figure 5-1-35 Performing the download

5.2 Connection between EX-1110 and PLC

5.2.1 Connection and Configuration between TIA Portal and EX-1110

1. Communication connection diagram, as shown in Figure 5-2-1.

Programming computer

Adapter

Figure 5-2-1 Communication connection diagram

2. Table 5-2-1 shows the hardware configuration

Table 5-2-1 Hardware configuration table

Hardware Quantity Note
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Computer programming 1 Install TIA Portal V16
The controller 1 S7-1212C
EX-1110 1 PROFINET adapter
EX-4014 1 Analog input module
EX-5014 1 Analog output module

Ethernet cable A number of

3. Install the GSD file

Open TIA Portal V16 and choose Options > Support Device Description File (GSD) from the
menu bar, as shown in Figure 5-2-2.

Figure 5-2-2 Installing GSD files

4. New project and equipment configuration

Open TIA Portal V16, select a new project and configure it, as shown in Figure 5-2-3.
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Figure 5-2-3 New construction project

To configure the device, expand the hardware directory in the network view and select the
adapter, as shown in Figure 5-2-4. Double-click the adapter to enter the CONFIGURATION I/O
module in the device view, as shown in Figure 5-2-5.

Figure 5-2-4 Configuring devices
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Figure 5-2-5 CONFIGURED I/O module

To assign controllers to I/OS in the network view, click Unassigned in the I/O module and
select PLC_1.PROFINET interface _1, as shown in Figure 5-2-6.

Figure 5-2-6 Assigning IO controllers

Set the IP address of the I/O module. In the device view, double-click the module to go to the
properties view, as shown in Figure 5-2-7.
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Figure 5-2-7 Assigning IP addresses

Assign a device name to a remote I/O module. Right-click the module and choose Assign
Device Name, as shown in Figure 5-2-8. Select the interface type, update the list, and assign the
device name, as shown in Figure 5-2-9.
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Figure 5-2-8 Assigning device names Figure 5-2-9 Writing device names

5. Program download and equipment monitoring

Select all devices in the network view and download, as shown in Figure 5-2-10. After
downloading the program, start CPU operation and switch to online monitoring for normal
communication, as shown in Figure 5-2-11.

Figure 5-2-10 Program download
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Figure 5-2-11 Device monitoring

5.2.2 Connection and Configuration between Step7 smart devices and EX-1110

1. Communication connection diagram, as shown in Figure 5-2-12.

Programming computer

Adapter

Figure 5-2-12 Communication connection diagram

2. Table 5-2-2 shows the hardware configuration

Table 5-2-2 Hardware configuration table

Hardware Quantity Note

Computer programming 1 Install STEP7 - MicroWIN
SMART

The controller 1 CPU ST40(DC/DC/DC)
EX-1110 1 PROFINET adapter
EX-4014 1 Analog input module
EX-5014 1 Analog output module
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Ethernet cable A number of

3. Install the GSD file

Open Step7-Microwin SMART, and choose GSDMLManagement from the menu bar, as
shown in Figure 5-2-13.

Figure 5-2-13 Installing GSD files

4. Assign the device name

On the menu bar, choose "Tools" > "Find PROFINET Device", select the network adapter
connected to the module in the window and find the device, select the module in the network and
edit its device name, as shown in Figure 5-2-14.

Note:

① When you select a NIC, two options are displayed for the same NIC, as shown in the following
figure. Select the NIC without Auto.

(2) After the device name is assigned, note that the device name must be the same as the assigned
name when configuring the IO module; otherwise, PLC cannot communicate with the IO module
normally.
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Figure 5-2-14 Assigning device names

5. New project and equipment configuration

On the menu bar, choose Tools > PROFINET, select the PLC role as the controller, as shown
in Figure 5-2-15, add the adapter, assign the device name (the same as the device name assigned
in Step 4 above) and IP address, as shown in Figure 5-2-16, add the IO module, as shown in
Figure 5-2-17, and select Generate.
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Figure 5-2-15 Selecting PLC roles

Figure 5-2-16 Adding an adapter
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Figure 5-2-17 Adding I/O modules

6. Program download

Choose "PLC" > "Download" in the menu bar, and select "Find CPU" in the communication
window, select the PLC that needs to download the program, and download the program.

Note: For PROFINET communication using STEP 7-Microwin SMART configuration 200 SMART, the
CPU firmware version of PLC must be ≥V2.4. For firmware = V2.3, you can directly upgrade the
firmware online. For firmware < 2.3, you must update the firmware with a memory card in the CPU.

5.2.3 Connection and Configuration between Step7 an Ex-1110

1. Communication connection diagram, as shown in Figure 5-2-18.

Programming computer

Adapter



EX Series Card I/O

Email:contact@welllinkio.com 109

Figure 5-2-18 Communication connection diagram

2. Table 5-2-3 shows the hardware configuration

Table 5-2-3 Hardware configuration table

Hardware Quantity Note

Computer programming 1 Install Step7 V5.6
The controller 1 315-2 PN/DP
EX-1110 1 PROFINET adapter
EX-4014 1 Analog input module
EX-5014 1 Analog output module

Ethernet cable A number of

3. Install the GSD file

After the new project is created, click "SIMATIC300", double click "Hardware", in the HW
Config window, choose "Options" > "Install GSD file" in the menu bar, as shown in Figure
5-2-19.

Figure 5-2-19 Installing GSD files

3. New project and equipment configuration

Open SIMATIC Manager, choose New Project from the menu bar, name the project, and
select a path to save the project, as shown in Figure 5-2-20.



EX Series Card I/O

Email:contact@welllinkio.com 110

Figure 5-2-20 New construction project

Add 300 sites to the project, as shown in Figure 5-2-21.Click the newly added site 300 and
select "Hardware" to enter the HW Config configuration interface, as shown in Figure
5-2-22.Add RACK Reil for RACK 300, as shown in Figure 5-2-23.To add a CPU module, click
HW Config, select CPU315-2 PN/DP VERSION V2.6 of CPU-300 in the right pane, and drag the
CPU module to slot 2 of the rack, as shown in Figure 5-2-24.In the Ethernet interface properties
interface, you can use other IP addresses as required, here use the default IP address and subnet
mask, and select the New button, create a new subnet Ethernet (1) click OK, as shown in Figure
5-2-25.
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Figure 5-2-21 Adding 300 sites

Figure 5-2-22 The HW Config page is displayed
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Figure 5-2-23 Adding rack Reil

Figure 5-2-24 Adding a CPU module to the rack
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Figure 5-2-25 Adding an Ethernet subnet

On Ethernet (1), configure the I/O device station. On the right, select EX-1110 and drag it
under the Ethernet (1) subnet, as shown in Figure 5-2-26.

Figure 5-2-26 Adding IO to an Ethernet (1) subnet

Add an I/O module, expand the right EX-1110, and drag the EX-4014 and EX-5014 to the
lower slot on the left, as shown in Figure 5-2-27.
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Figure 5-2-27 Adding an I/O module

To change the IP address of the I/O device station, double-click the DEC module in the
subnet and choose Ethernet in the Properties window. You can change the IP address in the
Ethernet properties window, as shown in Figure 5-2-28.

Figure 5-2-28 Changing the MODULE IP address

Set the device name for the I/O module, select the subnet icon, choose PLC on the menu bar,
Ethernet > Assign Device Name, as shown in Figure 5-2-29. In the Assign Device name window,
select the name to assign, and press Ok.
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Figure 5-2-29 Assigning device names

To check whether the name is assigned successfully, select the subnet icon, choose PLC on
the menu bar, and Ethernet > Verify Device Name, as shown in Figure 5-2-30.

Figure 5-2-30 Verifying the device name

5.2.4 Connection and configuration between CODESYS and EX-1110

1. Communication connection diagram, as shown in Figure 5-2-31.
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Programming computer

Adapter

Figure 5-2-31 Communication connection diagram.

2. Table 5-2-4 shows the hardware configuration

Table 5-2-4 Hardware configuration table

Hardware Quantity Note

Computer programming 1 Install the Codesys V3.5
EX-1110 1 PROFINET adapter
EX-4014 1 Analog input module
EX-5014 1 Analog output module

Ethernet cable A number of

2. Install the GSD file

Open CODESYS V3.5 and choose Tools > Device Repository from the menu bar, as shown
in Figure 5-2-32.
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Figure 5-2-32 Installing GSD files

4. New project and equipment configuration

Open CODESYS V3.5 software and choose "New Project" > "Project" > "Standard Project",
as shown in Figure 5-2-33.
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Figure 5-2-33 New construction project

In the standard engineering window, select CODESYS SoftMotion Win V3 for device and
Structured Text (ST) for PLC_PRG programming language, as shown in Figure 5-2-34.

Figure 5-2-34 Selecting device and programming language

Choose Device (CODESYS SoftMotion Win V3) > Add Device in the Device tree to add the
Ethernet adapter and PROFINET IO master station, as shown in Figure 5-2-35 and 5-2-36.

Tip: PROFINET IO configuration in the original Codesys software, if an error is reported that the
library is lost, the user needs to manually double click the library manager and choose to download
the lost library in the library manager window. This process requires the computer to connect to the
network.In addition, pay attention to the IP address and network segment of the network port
connected to the I/O device. Otherwise, the IP address of the I/O device may be in different network
segments.

Figure 5-2-35 Adding an Ethernet adapter
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Figure 5-2-36 Adding PROFINET IO master station

Double-click Ethernet in the device tree to assign Ethernet ports and set IP parameters for the
PROFINET IO master station, as shown in Figure 5-2-37 and 5-2-38.

Figure 5-2-37 Ethernet distribution network ports

Figure 5-2-38 Setting the PROFINET IO master IP address
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Download the program to the controller and start running, and then log out.Right-click
PN_Controller and choose Scan Devices. In the device window, select the module and assign the
device name and IP address, as shown in Figure 5-2-39.Copy the device into the project, as
shown in Figure 5-2-40.

Figure 5-2-39 Assigning names and IP addresses

Figure 5-2-40 Copying equipment into project

5. Program download and equipment monitoring

Download the project to the controller and start the operation and monitoring, as shown in
Figure 5-2-41.
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Figure 5-2-41 Program download and monitoring
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5.3 Connection between Ex-1010 and PLC

Note: cX-One and EX-1010 have manual and automatic communication configurations. Please refer to
details 4 and 5 in 5.3.1 for details.

5.3.1 Connection and Configuration between CX-One and EX-1010

1. Communication connection diagram, as shown in FIG. 5-3-1.

Programming computer

Adapter

Figure 5-3-1 Communication connection diagram

Note: The power interface above the DeviceNet adapter needs to be separately connected to DC24V
power supply. Terminal resistors (121 ω) need to be added to the two terminals in the network, as shown
in Figure 5-3-2.

termination
resistor

termination
resistor

Slave station#nSlave station#2Slave station#1Master station

Figure 5-3-2 Terminal resistance wiring

2. Hardware configuration is shown in Table 5-3-1

Table 5-3-1 Hardware configuration table

Hardware Quantity Note

Computer programming 1 CX-one

The controller 1 CJ2M/
CJ1W-DR2M
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EX-1010 1 DeviceNet adapter

EX-200H 1 Digital quantity input
module

EX-310H 1 Digital output module
DeviceNet

communications line A number of

3. Install the EDS file

Open cX-Integrator configuration software, and choose Tools > DeviceNet Tools > Edit
Configuration File > Vendor ID/ Device Type Table from the menu bar, as shown in Figure 5-3-2.

Figure 5-3-2 Installing the EDS file

4. Equipment configuration (automatic scanning)

Open CX-Integrator configuration software, choose "Network" > "Communication Settings"
from the menu bar, and select THE PLC model as "CJ2M (CPU model: CPU31)", as shown in
Figure 5-3-3.
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Figure 5-3-3 Configuring the CPU

Automatic scanning, click "Online Work button", double-click DeviceNet[CJ1W-DRM21]
network (-), node (1), unit (0), and set the network name, confirm transmission, as shown in
Figure 5-3-4.Double-click ex-102 to see if OMron PLC scans to ex-1020 slave station and IO
module.

Figure 5-3-4 Automatic scanning

Right-click to scan the EX-1010 icon, choose Properties, choose I/O Info > Edit, and
configure the number of input/output bytes for the adapter according to the input/output bytes size,
as shown in Figure 5-3-5.
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Figure 5-3-5 Edit the input and output bytes

5. Equipment configuration (manual configuration)

"New Project" on the right, select "Plug in Network" and "DeviceNet", as shown in Figure
5-3-6.
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Figure 5-3-6 inserting into the network

Add the DeviveNet communication module CJ1W-DRM21 and then add the IO device.
Right-click the network icon and choose Insert Component. In the wizard window, select
EX-1010, as shown in Figure 5-3-7.

Figure 5-3-7 Insert ex-1010

On the network, double-click EX-1010, and add the I/O module (for example, EX-310H and
EX-200H) in the edit device parameter window that is displayed, as shown in Figure 5-3-8.
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Figure 5-3-8 Adding an IO module

Right-click EX-1010 on the network and choose Properties. In the EX-1010 properties
window, choose I/O Info > Edit, as shown in Figure 5-3-9.

Figure 5-3-9 Edit the size of input and output bytes

6. Download configuration information

Right-click the CJ1W-DR2m icon and choose Parameters > Edit, as shown in Figure 5-3-10.
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Figure 5-3-10 Opening parameter editing

In the edit device parameter window, select "Register button" to register the slave device, as
shown in Figure 5-3-11.After successful registration, you can see the PLC internal address
corresponding to the input and output of the slave I/O module. Finally, click the "Download"
button to download the configuration information to PLC, as shown in Figure 5-3-12.After
downloading, you can observe that the NET RUN indicator on the adapter lights up and the SYS
indicator flashes once per second.
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Figure 5-3-11 Slave device registration

Figure 5-3-12 Download configuration
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5.4 Connection and configuration between Codesys and EX-1130

5.5 Connection between EX-1040 and PLC

5.5.1 Connection and Configuration between GX-WORKS2 and EX-1040

1. Communication connection diagram, as shown in Figure 5-5-1.

Programming computer

Adapter

Figure 5-5-1 Communication connection diagram

Note: Add terminal resistors (110 ω) to the two terminals in the network, as shown in Figure 5-5-2 below.

termination
resistor

termination
resistor

Master station Slave station#1 Slave station#2 Slave station#n

Figure 5-5-2 Terminal resistance cable connection

2. Table 5-5-1 shows the hardware configuration

Table 5-5-1 Hardware configuration table

Hardware Quantity Note

Computer programming 1 Install the GXWorks2. -
PLC 1 Supports CC-link

EX-1040 1 CC - Link adapters

EX-2008 1 Digital quantity input
module

EX-3008 1 Digital output module
CC - Link communication

lines A number of
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3. New project and communication parameter configuration

Open gX-WorkS2 software, select the actual site CPU model, and then choose Parameter >
Network Parameter > CC-Link in the left navigation bar of the project. In the CC-Link parameter
setting window, set the PARAMETERS of CC-Link slave station, as shown in Figure 5-5-3. As
shown in Figure 5-5-4.

Figure 5-5-3 Opening the cc-link parameter setting window

Figure 5-5-4 CC-link parameter Settings

Configure slave information. On the CC-link parameter setting screen, select Station
Information to set parameters such as the station type, as shown in Figure 5-5-5.
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Figure 5-5-5 Configuring slave parameters

For details on the slave station parameters, see 2.1.6 CC-Link Adapter. The setting rules of ex-1040 as
the remote device station are as follows:

The station information of THE CC-Link adapter EX-1040 in the Mitsubishi GX-Works software is
the remote device station, one station is 32 points, which can be set according to the specific IO points
connected by the user after the EX-1040. The maximum number of logical stations can be set, and a single
logical station contains 32 points. Amaximum of 4 x (32DI+32DO+4 ai +4 ao) can be connected.

The CC-Link remote IO adapter supports two logical station Settings, based on the first and last
five bits of baud rate dip. The first five digits of the DIP switch correspond to the layer 5 communication
rate, which is a fixed four logical stations. The number cannot be changed by default. When the dip switch
is set to the last five digits, the number of logical stations can be changed as required. The communication
rate of the first five digits remains the same. You can flexibly configure the logical stations as required. A
set of 16-point digital inputs and outputs is a logical station, and a set of 4-channel analog inputs is a
logical station.

For example, if the PLC is connected to five groups of EX-1040, and one group of EX-1040 is
connected to the other two groups of EX-200H, EX300H, EX-4414, and EX-5414, the communication rate
should be based on the master station. For details, see Table 5-5-6.

Table 5-5-6 communication parameter Settings

CC-link Dip switch corresponds to the station id

Rate distance

corresponding to

dip station number

Fixed logic

station

Dial the

code: 0

Dial the

code: 1

Dial the

code: 2

Dial the

code: 3

Dial the code:

4

Variable logic

station

Dial the

code: 5

Dial the

code: 6

Dial the

code: 7

Dial the

code: 8

Dial the code:

9

CC-link Communication rate and

transmission distance

156kbps 625kbps 2.5 Mbps 5Mbps 10Mbps

1200m 600m 200m 150m 100m
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Based on ex-200H, EX300H, EX-4414, and EX-5414, the I/O module has a set of 32-point I/O inputs
and outputs. One set of 4-channel analog inputs and the other set of 4-channel analog outputs. The
maximum number of logical stations is 1 logical station. Specifically, the number of the first group is 1,
the second group is 2, the third group is 3, and so on.
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5.6 Connection between EX-1030 and PLC

Figure 5-6-1 shows the process for restoring the Modbus RTU module to factory Settings and setting
parameters.

Power off
All Dials Set to 0

Restart Power
Waiting to Restore
Factory Settings

Power off
Configuration parameters
(address, communication

rate)

Restart to take effect

Figure 5-6-1 Process for restoring factory Settings

Note: the module is restored to factory Settings, only the parameters set by the user are cleared, such as
watchdog activation, watchdog time, etc.

Module address The IP addresses of the input and output channels are related to the positions of modules.
The Modbus RTU function codes used by modules remain unchanged. Figure 5-6-2 shows an example.

Adapter

Function code Function code

Address Address
Address Address

Address
Address

Address：

Function code Function code Function code Function code Function code

Function code Function code Function code Function code Function code Function code Function
code

Address Address
Address Address

Address
Address

Address

Figure 5-6-2 Module address allocation

5.6.1 Connection and Configuration between Modbus Poll software and EX-1030

1. Communication connection diagram, as shown in Figure 5-6-3.

Communication parameters in the case: baud rate 9600bps, data bit 8, stop bit 1, no check;The slave
address is 1.

Adapter
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Computer installation

Adap ter

Figure 5-6-3 Communication connection diagram

2. Table 5-6-1 shows the hardware configuration

Table 5-6-1 Hardware configuration table

hardware Quantity note

Computer programming 1 Install the Modbus Poll
EX-1030 1 Modbus RTU adapter
EX-2008 1 Digital quantity input module
EX-3008 1 Digital output module
EX-4014 1 Analog input module
EX-5014 1 Analog output module

USB to 485 serial port 1

3. Set the ex-1030 communication parameters as shown in Table 5-6-2

Table 5-6-2 Communications parameter Settings

The name of the Set the value note

Communication rate 9600bps
The communications rate dip

switch is set to 5
Data bits 8 The default value
Parity bit There is no The default is
Stop bit 1 The default value

From the station address 1

Address DIP switch x 1 Set
this parameter to 1

Address DIP switch x 10 is
set to 0

4. Dip switch, as shown in Figure 5-6-4. Table 5-6-3 lists the dip switch parameters.
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Communicati
on rate setting

Dial setting
×10

Dial setting ×1

Figure 5-6-4 DIP switch

Table 5-6-3 Dip switch parameters

Communication rate
Dip switch value

Baud rate value note

0 -
1 115200
2 57600
3 38400
4 19200
5 9600
6 4800
7 2400
8 1200
9 -

For the Modbus RTU address, calculate the formula (N1 x 1 DIP switch, n2 x 10 DIP switch) :
Address = N1 x 1+ N2 x 10.

5. Table 5-6-4 lists the Modbus RTU function codes supported by the EX-1030 adapter

Table 5-6-4 Modbus RTU function codes

Function
code

function
Functional meaning note

0x01
Read

Read digital output
For example, the
EX-3XXX module

0x02
Read Read digital quantity

input
For example, the ex-2XXX

module

0x03
Read

Read analog output
For example, the
EX-5XXX module

0x04
Read

Read analog input
For example, the
EX-4XXX module

0x05 Write Write a single numeric For example, the
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quantity EX-3XXX module

0x06
Write Write a single analog

quantity
For example, the
EX-5XXX module

0x0F
Write Write multiple numeric

quantities
For example, the
EX-3XXX module

0x10
Write Write multiple analog

quantities
For example, the
EX-5XXX module

Modbus Poll configuration and communication

Create a File Read ex-4014 module channel, select "New" from "File" in the menu bar, right click the
blank channel, and choose "Read/ Write Definition", as shown in Figure 5-6-5.

Figure 5-6-5 Channel configuration

The configuration parameters read the ex-4014 module data, including the slave address, function
code, start address, and read address length (in the case of ex-1030, the address is set to 1), as shown in
Figure 5-6-6.

Figure 5-6-6 Configuration parameters

New file Configuration parameters Read the data of the EX-5014 module, including the slave address,
function code, start address, and read address length (in the case of ex-1030, the address is set to 1), as
shown in Figure 5-6-7.
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Figure 5-6-7 Configuration parameters

New file Configuration parameters Read the data of ex-2008 module, including the slave address,
function code, start address, and read address length (in the case of EX-1030, the address is set to 1), as
shown in Figure 5-6-8.

Figure 5-6-8 Configuration parameters

New file Configuration parameters Read the data of the EX-3008 module, including the slave address,
function code, start address, and read address length (in the case of ex-1030, the address is set to 1), as
shown in Figure 5-6-9.

Figure 5-6-9 Configuration parameters
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Create a file to write data to EX-5014. The parameters include the slave address, function code, start
address, and read address length (in the case of EX-1030, the address is set to 1), as shown in Figure
5-6-10.

Figure 5-6-10 Configuration parameters

Create a file to write data to ex-2008. The parameters include the slave address, function code, start
address, and read address length (in the case of EX-1030, the address is set to 1), as shown in Figure
5-6-11.

Figure 5-6-11 Setting parameters

Connect to ex-1030 through the USB-485 serial port module. Set parameters in the Modbus Poll
software. Select Connect from the menu bar to set communication parameters, as shown in Figure 5-6-12.
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Figure 5-6-12 Communication parameter configuration

7. After the communication connection is completed, monitor the module status and write values to the
DO/AO channel.

5.6.2 Connection and Configuration between Codesys and EX-1030

1. Communication connection diagram, as shown in Figure 5-6-15.

Communication parameters in the case: baud rate 115200bps, data bit 8, stop bit 1, no check;The slave
address is 5.

Controller
Programming computer

Adapter

Figure 5-6-15 Communication connection diagram

2. Table 5-6-5 shows the hardware configuration

Table 5-6-5 Hardware configuration table

hardware Quantity note

Computer programming 1 Install the Codesys SP16
The controller 1
EX-1030 1 Modbus RTU adapter
EX-2008 1 Digital quantity input module
EX-3008 1 Digital output module
EX-4014 1 Analog input module
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EX-5014 1 Analog output module

3. New project and equipment configuration

Open Codesys programming software and configure communication, as shown in Figure 5-6-16.
Double-click "Modbus_COM" to configure communication port and communication parameters, as shown
in Figure 5-6-17. Configure the master station protocol and corresponding timeout parameters, as shown in
Figure 5-6-18. The address corresponding to the slave channel is shown in Figure 5-6-21.

Figure 5-6-16 Configuration communication

Figure 5-6-17 Configuring ports and communication parameters

Figure 5-6-18 Configuring the master protocol and related timeout parameters
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Figure 5-6-19 Setting the slave address

Figure 5-6-20 Adding a slave channel

Figure 5-6-21 Address corresponding to the slave channel

The program was programmed to define four variables and associate them with the actual physical
address, as shown in Figure 5-6-22.

Figure 5-6-22 Programming
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5.6.3 Connection and Configuration between TIA Portal and EX-1030.

1. Communication connection diagram, as shown in Figure 5-6-23.

Communication parameters in the case: baud rate 115200bps, data bit 8, stop bit 1, no check;The slave
address is 5.

Programming computer

Adapter

Figure 5-6-23 Communication connection diagram

2. Table 5-6-7 shows the hardware configuration

Table 5-6-7 Hardware configuration table

hardware Quantity note

Computer programming 1 Install the Codesys SP16
PLC 1 S7-1212C

Communication module 1 CM1241
EX-1030 1 Modbus RTU adapter
EX-2008 1 Digital quantity input module
EX-3008 1 Digital output module
EX-4014 1 Analog input module
EX-5014 1 Analog output module

3. New project and equipment configuration

Open the TIA Portal V16 programming software and configure the hardware, as shown in Figure
5-6-24. In the network view, double-click the CPU to enter the properties, select "System and Clock
Memory", and select "Enable System Memory Bytes" and "Enable Clock Memory Bytes", as shown in
Figure 5-6-25. Configure the CM1241 interface parameters. Double-click CM1241 to enter the properties
and select "Port Configuration" to set communication parameters, as shown in Figure 5-6-26.
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Figure 5-6-24 Configuration hardware

Figure 5-6-25 Enabling system storage and clock storage

Figure 5-6-26 Setting communication parameters

Add the function block "MB_MASTER" of Modbus RTU master station to OB1, and write the polling
program. The bit count value of program segment 1 is automatically increased by 1, and program segment
2 is the value of reading the 8 channels of EX-2008, as shown in Figure 5-6-27.Program section 3 is to
write the values of the 8 channels of EX-3008, and program section 4 is to read the values of the first
channel of EX-4014, as shown in Figure 5-6-28.The program section 5 is the value written to the first
channel value of EX-5014, as shown in Figure 5-6-29.
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Figure 5-6-27 Program segment 1 and program segment 2
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Figure 5-6-28 Program segment 3 and program segment 4

FIG. 5-6-29 Program section 5
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Add an organization block OB100 to the program block, add a Modbus RTU configuration port
function block to the program block, and configure the function block pins, as shown in Figure 5-6-30.

Figure 5-6-30 Adding OB100 tissue block

4. Program download and monitoring

Add a new monitoring list and add the variables that you want to monitor, as shown in Figure
5-6-31.Compile and download the program into PLC, and monitor the variables in the program, as shown
in Figure 5-6-32.

Figure 5-6-31 Adding variables to be monitored

Figure 5-6-32 Monitoring variable values
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5.7 Connection between EX-1120 and PLC

5.7.1 Connection and Configuration between Machine Expert and EX-1120

Note:

(1) The IP address segment is 192.168.0.X by default. You can use the IP Setting Tool to change the network segment
and set the IP address of the adapter dip switch.

② On the right of ex-1120, input and output bytes for communication between IO module and EtherNet/IP are
configured

If the ex-1120 has only input or output modules on the right, the output (O-->T) byte length is set to 1Byte or
the input (T- >O) byte length is set to 1Byte. If neither I/O module is available, the input (T- >O) byte length and
output (O- >T) byte length are set to 1Byte.

③ Ex-1120 adapter includes two TYPES of PLC mode: normal PLC mode and special PLC mode.Special PLC
refers to keens PLC, ordinary PLC refers to the other manufacturers except keens PLC, factory default PLC category
mode for ordinary PLC.

The hardware
configuration

Input (T- >O)

bytes

Output (O- >T)

bytes

EX-1120 1 1
EX-1120
EX-200H

2 1

EX-1120
EX-300H

1 2

EX-1120
EX-200H
EX-300H

2 2

1. Communication connection diagram, as shown in Figure 5-7-1

Programming computer

Adapter

Figure 5-7-1 Communication connection diagram

2. Table 5-7-1 shows the hardware configuration
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Table 5-7-1 Hardware configuration table

hardware Quantity note

Computer programming 1 Install Machine Expert V2.0
PLC 1 M241

EX-1120 1 EtherNet/IP adapter
EX-200H 1 Digital quantity input module
EX-300H 1 Digital output module
EX-4014 1 Analog input module
EX-5014 1 Analog output module

3. Set the IP address

In this example, the IP address of schneider M241 PLC is 192.168.1.39, and the default network
segment of ex-1120 adapter is 192.168.0.x.

① Use software IP Setting Tool to modify the network segment to be consistent with PLC;

② Set the IP address to 192.168.1.33 through the DIP switch on the adapter.

4. Install the EDS file

On the menu bar, choose Tools > Device Repository. In the device repository window, choose Install,
as shown in Figure 5-7-2. In the EDS folder, choose General Version > EX-1120_V1.1 and confirm the
installation.

Figure 5-7-2 Installing the EDS file
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5. New project and equipment configuration

Start Machine Expert V2.0, create a project, right-click "EtherNET_1" in the device tree, and choose
"Add Device", as shown in Figure 5-7-3.

Choose Protocol Manager > Industrial Ethernet Manager in the Add Device window, as shown in
Figure 5-7-4. Right-click "_(Industrial Ethernet Manager)" > Add Device in the device window. Select
DECOWELLAUTOMATION CO.,LTD for the supplier and ex-1120 in the equipment catalog, as shown
in Figure 5-7-5.

Figure 5-7-3 Adding devices

Figure 5-7-4 Adding an industrial Ethernet manager



EX Series Card I/O

Email:contact@welllinkio.com 151

Figure 5-7-5 Adding ex-1120

To configure ex-1120 parameters, double-click EX-1120 in the device tree, and set the IP address to a
fixed IP address, as shown in Figure 5-7-6.

Figure 5-7-6 Configuring an IP address

Number of bytes occupied by computing modules:
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Table 5-7-2 Number of bytes occupied by modules

The module
type

Quantity
Input/output type

Occupied bytes

EX-2xx8 1 Input (T- >O) 1

EX-2xxH 1 Input (T- >O) 2
EX-2xxS 1 Input (T- >O) 4
EX-3xx8 1 Output (O- >T) 1
EX-3xxH 1 Output (O- >T) 2
EX-3xxS 1 Output (O- >T) 4
EX-4xx4 1 Input (T- >O) 8
EX-4xx8 1 Input (T- >O) 16
EX-5xx4 1 Output (O- >T) 8
EX-5xx8 1 Output (O- >T) 16

To configure connection parameters, double-click the default connection parameters, and set the
output bytes (O- >T) to 10 bytes and the input bytes (T- >O) to 10 bytes in the edit connection window, as
shown in Figure 5-7-7. View the IO address mapping, as shown in Figure 5-7-8.

Figure 5-7-7 Configuring the input/output byte size
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Figure 5-7-8 IO address mapping

The physical address assignment corresponding to the actual module in the case:

Note: In actual hardware, the number of I/O modules configured for the EX-1120 adapter is the same as
that of the model, but the sequence of the MODULES is different, and the physical address assignment
for the modules is different, as shown in Figure 5-7-9 and 5-7-10.

Adapter

Figure 5-7-9 I/O sorting and address assignment #1(application in case)

Adapter

Figure 5-7-10 I/O sorting and address assignment #2

In EtherNet/IP I/O mapping, always update variable is selected as "Enable 2 (always in bus cycle
task)", and the program is downloaded into PLC, and the PLC running status and I/O mapping address are
monitored, as shown in Figure 5-7-11.

Figure 5-7-11 Program download and monitoring

5.7.2 Connection and Configuration between CODESYS and EX-1120

Note:
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(1) The IP address segment is 192.168.0.X by default. You can use the IP Setting Tool to change the network segment
and set the IP address of the adapter dip switch.

② On the right of ex-1120, input and output bytes for communication between IO module and EtherNet/IP are
configured

If the ex-1120 has only input or output modules on the right, the output (O-->T) byte length is set to 1Byte or
the input (T- >O) byte length is set to 1Byte. If neither I/O module is available, the input (T- >O) byte length and
output (O- >T) byte length are set to 1Byte.

③ Ex-1120 adapter includes two TYPES of PLC mode: normal PLC mode and special PLC mode.Special PLC
refers to keens PLC, ordinary PLC refers to the other manufacturers except keens PLC, factory default PLC category
mode for ordinary PLC.

The hardware
configuration

Input (T- >O)

bytes

Output (O- >T)

bytes

EX-1120 1 1
EX-1120
EX-200H

2 1

EX-1120
EX-300H

1 2

EX-1120
EX-200H
EX-300H

2 2

1. Communication connection diagram, as shown in Figure 5-7-12

Adapte

Controller
Programming

Figure 5-7-12 Communication connection diagram

2. Table 5-7-3 shows the hardware configuration

Table 5-7-3 Hardware configuration table
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hardware Quantity note

Computer programming 1 Install the CODESYS SP16
The controller 1
EX-1120 1 EtherNet/IP adapter
EX-200H 1 Digital quantity input module
EX-300H 1 Digital output module
EX-4014 1 Analog input module
EX-5014 1 Analog output module

3. Set the IP address

In this case, the IP address of the CODESYS controller is 192.168.1.198, and the default network
segment of the ex-1120 adapter is 192.168.0.x.

① Use software IP Setting Tool to modify the network segment to be consistent with PLC;

② Set the IP address to 192.168.1.33 through the DIP switch on the adapter.

4. Install the EDS file

On the menu bar, choose Tools > Device Repository. In the device repository window, choose Install,
as shown in Figure 5-7-13. In the EDS folder, choose General Version > EX-1120_V1.1 and confirm the
installation.

Figure 5-7-13 Installing the EDS file

5. New project and equipment configuration

Open CODESYS SP16, create a project, right-click Device in the Device tree, and choose Add
Device. In the add Device window, choose Ethernet, as shown in Figure 5-7-14.
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Right-click Ethernet in the device tree and choose Add Device. In the add Device window, choose
Ethernet /IP Scanner, as shown in Figure 5-7-15.

Figure 5-7-14 Adding an Ethernet adapter

Figure 5-7-15 Adding the EthernetIP scanner

To configure the network adapter, double-click Ethernet in the device tree and select the network
adapter to communicate with the Ethernet /IP slave, as shown in Figure 5-7-16.



EX Series Card I/O

Email:contact@welllinkio.com 157

Figure 5-7-16 Configuring the network adapter for the Ethernet adapter

Right-click EtherNet_IP_Scanner in the device tree and choose Add Device. In the add device
window, select EX-1120, as shown in Figure 5-7-17.

Figure 5-7-17 Adding the EX-1120 adapter

To configure the IP address of the EX-1120 adapter, double-click EX_1120 in the device tree, and
enter the IP address (the IP address must be the same as that of the actual module), as shown in Figure
5-7-18.
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Figure 5-7-18 Configuring the IP address of the ex-1120 adapter

Number of bytes occupied by computing modules:

Table 5-7-4 Number of bytes occupied by modules

The module
type

Quantity
Input/output type

Occupied bytes

EX-2xx8 1 Input (T- >O) 1

EX-2xxH 1 Input (T- >O) 2
EX-2xxS 1 Input (T- >O) 4
EX-3xx8 1 Output (O- >T) 1
EX-3xxH 1 Output (O- >T) 2
EX-3xxS 1 Output (O- >T) 4
EX-4xx4 1 Input (T- >O) 8
EX-4xx8 1 Input (T- >O) 16
EX-5xx4 1 Output (O- >T) 8
EX-5xx8 1 Output (O- >T) 16

Set the input and output bytes of the I/O module of the EX-1120 adapter (you need to set the input
and output bytes based on the actual NUMBER of I/O modules to ensure normal communication), as
shown in Figure 5-7-19. Then view the I/O mapping of EtherNet/IP communication, as shown in Figure
5-7-20.



EX Series Card I/O

Email:contact@welllinkio.com 159

Figure 5-7-19 Configuring the size of input and output bytes

Figure 5-7-20 IO address mapping

The physical address assignment corresponding to the actual module in the case:

Note: In actual hardware, the number of I/O modules configured for the EX-1120 adapter is the same as
that of the model, but the sequence of the MODULES is different, and the physical address assignment
for the modules is different, as shown in Figure 5-7-21 and 5-7-22.

Adapter
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Figure 5-7-21 I/O sorting and address assignment #1(application in case)

Adapter

Figure 5-7-22 I/O sorting and address assignment #2

In EtherNet/IP I/O mapping, always update variable is selected as "Enable 2 (always in bus cycle
task)", and the program is downloaded into PLC, and the PLC running status and I/O mapping address are
monitored, as shown in Figure 5-7-23.

Figure 5-7-23 Program download and monitoring

5.7.3 Connection and Configuration between Sysmac Studio and EX-1120

Note:

(1) The IP address segment is 192.168.0.X by default. You can use the IP Setting Tool to change the network segment
and set the IP address of the adapter dip switch.

② On the right of ex-1120, input and output bytes for communication between IO module and EtherNet/IP are
configured

If the ex-1120 has only input or output modules on the right, the output (O-->T) byte length is set to 1Byte or
the input (T- >O) byte length is set to 1Byte. If neither I/O module is available, the input (T- >O) byte length and
output (O- >T) byte length are set to 1Byte.

③ Ex-1120 adapter includes two TYPES of PLC mode: normal PLC mode and special PLC mode.Special PLC
refers to keens PLC, ordinary PLC refers to the other manufacturers except keens PLC, factory default PLC category
mode for ordinary PLC.

The hardware
configuration

Input (T- >O) Output (O- >T)
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bytes bytes

EX-1121 1 1
EX-1121
EX-200H

2 1

EX-1121
EX-300H

1 2

EX-1121
EX-200H
EX-300H

2 2

1. Communication connection diagram, as shown in Figure 5-7-24

Adapter

Programming computer

Figure 5-7-24 Communication connection diagram

2. Table 5-7-5 shows the hardware configuration

Table 5-7-5 Hardware configuration table

hardware Quantity note

Computer programming 1 Install the Sysmac Studio
NX1P2 1
EX-1120 1 EtherNet/IP adapter
EX-200H 1 Digital quantity input module
EX-300H 1 Digital output module
EX-4014 1 Analog input module
EX-5014 1 Analog output module

3. Set the IP address

In this case, the IP address of omron NX1P2 PLC is 192.168.1.39, and the default network segment of
ex-1120 adapter is 192.168.0.x.

① Use software IP Setting Tool to modify the network segment to be consistent with PLC;

② Set the IP address to 192.168.1.33 through the DIP switch on the adapter.
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4. New project and equipment configuration

Open the Sysmac Studio programming software creation project and configure the EtherNet/IP port as
a fixed IP address (the same as the ACTUAL PLC port IP address), as shown in Figure 5-7-25.

Figure 5-7-25 EtherNet/IP port Settings

Create all variables, and create input and output variables in global variables. The length of the
variables must be the same as the length of input and output bytes in the actual module, as shown in Figure
5-7-26.

Number of bytes occupied by computing modules:

Table 5-7-6 Number of bytes occupied by modules

The module
type

Quantity
Input/output type

Occupied bytes

EX-2xx8 1 Input (T- >O) 1

EX-2xxH 1 Input (T- >O) 2
EX-2xxS 1 Input (T- >O) 4
EX-3xx8 1 Output (O- >T) 1
EX-3xxH 1 Output (O- >T) 2
EX-3xxS 1 Output (O- >T) 4
EX-4xx4 1 Input (T- >O) 8
EX-4xx8 1 Input (T- >O) 16
EX-5xx4 1 Output (O- >T) 8
EX-5xx8 1 Output (O- >T) 16
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Figure 5-7-26 Creating global variables

On the menu bar, choose Tools > EtherNet/IP Connection Settings. In the EtherNet/IP list window,
double-click the node address to open the EtherNet/IP port connection Settings window, as shown in
Figure 5-7-27.

Figure 5-7-27 Opening the built-in EtherNet/IP port Settings connection Settings window

Register variables. In the built-in EtherNet/IP port Settings connection Settings window, select "Label
Groups" window and click "Register All" to register the newly created global variables, as shown in Figure
5-7-28.
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Figure 5-7-28 Registered variables

Install the EDS file, right-click in the blank area of the toolbox on the right of the connection setting
window, and choose Show EDS Library, as shown in Figure 5-7-29.In the EDS library window, click
Install to open the EDS file to be installed, as shown in Figure 5-7-30.

Figure 5-7-29 shows the EDS library
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Figure 5-7-30 Installing the EDS file

To add devices to communicate with and set parameters, select "Add Target Device" in the toolbox, as
shown in Figure 5-7-31. Enter the EtherNet/IP slave IP address, slave model, and revised version, and
click "Add" in the lower left corner of the motor.

Figure 5-7-31 Adding a target device

Drag the target device 192.168.1.33 EX-1120 version 1 from the toolbox to the connection, as shown
in Figure 5-7-32.

Set the target device parameters. The input target variable of ex-1120 is 100, the output target variable
is 101, the input and output bytes are 10, and the start variable is the global variable registered, as shown
in Figure 5-7-33.

Switch PLC to online, and switch PLC to programming mode, and then select "Send to Controller", as
shown in Figure 5-7-34;

Transfer PLC online, and then download the program into PLC. IO module sequencing corresponds to
the actual address, as shown in Figure 5-8-35 and 5-8-36.
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Figure 5-7-32 Adding a connected device

Figure 5-7-33 Configuring target device parameters

Figure 5-7-34 Transferring the EtherNet/IP configuration to the controller
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Channel/mo

dule

EX-1120 EX-200H EX-300H EX-4014 EX-5014

Channel 0 - Input[0][l] Output[0][l] Input[2] [3] Output[2][3]

Channel 1 - - - Input[4] [5] Output[4][5]

Channel 2 - - - Input[6][7] Output[6] [7]

Channel 3 - - - Input[8][9] Output[8][9]

Figure 5-7-35 Mapping between IO module sequencing and actual address (application in case)

Channel/mo

dule

EX-1120 EX-4014 EX-5014 EX-200H EX-300H

Channel 0 - Input[0][l] Output[0][l] Input[8] [9] Output[8][9]

Channel 1 - Input[2] [3] Output[4][5] - -

Channel 2 - Input[4] [5] Output[6] [7] - -

Channel 3 - Input[6][7] Output[8][9] - -

Figure 5-7-36 Mapping between I/O module sequencing and actual addresses

5.7.4 Connection and configuration between KV STUDIO and EX-1120

Note: The default IP address segment is 192.168.0.X. You can use the IP Setting Tool to modify the IP address
segment and set the IP address with the DIP switch of the adapter.

The EX-1120 adapter includes two TYPES of PLC modes: normal PLC and special PLC mode.Special PLC
refers to keens PLC, ordinary PLC refers to the other manufacturers except keens PLC, factory default PLC category
mode for ordinary PLC.

1. Communication connection diagram, as shown in Figure 5-7-37

Programming computer

Adapter

Figure 5-7-37 Communication connection diagram

2. Table 5-7-7 shows the hardware configuration

Table 5-7-7 Hardware configuration table

hardware Quantity note



EX Series Card I/O

Email:contact@welllinkio.com 168

Computer programming 1 Install the KV STUDIO
PLC 1 KV-5500

EX-1120 1 EtherNet/IP adapter
EX-200H 1 Digital quantity input module
EX-300H 1 Analog output module
EX-4014 1 Analog input module
EX-5014 1 Analog output module

3. Set the IP address

In this case, the IP address of KV-5500 PLC is 192.168.1.31, and the default network segment of
ex-1120 adapter is 192.168.0.x.

① Use software IP Setting Tool to modify the network segment to be consistent with PLC;

② Set the IP address to 192.168.1.33 through the DIP switch on the adapter.

4. Copy XML files

Copy all files in the "Keens Version" folder to the KV STUDIO software folder:

"C: \ ProgramData \ KEYENCE \ KVS11G_Trial \ KVS \ EIP_Eds"

5. New project and equipment configuration

Open KV STUDIO software, create a new project, and double-click "EtherNet/IP" in the project
device tree to open the EtehrNET/IP Settings window, as shown in Figure 5-7-38.

Figure 5-7-38 Opening the EtherNet/IP Settings window

Install the EDS file. On the menu bar of the EtherNet/IP configuration window, choose EDS File >
Login. In the EDS folder, choose Common Version > EX-1120, as shown in Figure 5-7-39.
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Figure 5-7-39 Installing the EDS file

Set the ex-1120 adapter mode to special PLC mode (the factory default is common mode). Right-click
the blank area in the device Search option on the right and choose Device Search, as shown in Figure
5-7-40.

Add the scanned devices to the scan list. Right-click the devices to be added and choose Add to scan
List, as shown in Figure 5-7-41.

For transmission adapter Settings, right-click "EX-1120" in the device list and choose "Transmission
Adapter Settings", as shown in Figure 5-7-42.

In the transfer adapter setting window, change the adapter No.100 setting value to "1: Special PLC"
and write the adapter, as shown in Figure 5-7-43. After the writing is complete, the EX-1120 must be
powered off and restarted.

In the EtherNet/IP Settings window, select KV-5500 and right click "Auto Configuration" to re-read
the EX-1120, as shown in Figure 5-7-44.
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Figure 5-7-40 Device search

Figure 5-7-41 Adding devices to the scan list

Figure 5-7-42 Adapter transfer Settings
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Figure 5-7-43 Write adapter

Figure 5-7-44 Re-reading ex-1120

Download the program into PLC, and choose "Monitoring/Simulator" > "PLC Transmission" from the
menu bar. After downloading, switch PLC to monitoring mode to monitor the communication status
between PLC and EX-1120, as shown in Figure 5-7-35.
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Figure 5-7-36 Monitoring the communication between PLC and EX-1120

5.8 Connection between EX-1121 and PLC

5.8.1 Connection and Configuration between Machine Expert and EX-1121

Note:

(1) The EX-1121 has two modes: special mode and normal mode. The special mode can only be used with
Keens CPU, and the factory default is normal mode.

② The ex-1121 works in BOOTP mode by default and does not have an IP address.For details about how to set
the IP address, see 6.3.6 SETTING the IPAddress of the EX-1121 Adapter.

③ In common mode, the input and output bytes of communication between THE IO module and EtherNet/IP
are configured on the right of ex-1121

If the ex-1121 has only input or output modules on the right, the output (O-->T) byte length is set to 1Byte
or the input (T- >O) byte length is set to 1Byte. If neither I/O module is available, the input (T- >O) byte length
and output (O- >T) byte length are set to 1Byte.

The hardware
configuration

Input (T- >O)

bytes

Output (O- >T)

bytes

EX-1121 1 1
EX-1121
EX-200H

2 1

EX-1121
EX-300H

1 2

EX-1121
EX-200H
EX-300H

2 2

1. Communication connection diagram, as shown in Figure 5-8-1

file:///C:/Users/一世安/Desktop/总%20德克威尔EX卡片式远程IO用户手册.docx
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Programming computer

Adapter

Figure 5-8-1 Communication connection diagram

2. Table 5-7-1 shows the hardware configuration

Table 5-8-1 Hardware configuration table

hardware Quantity note

Computer programming 1 Install Machine Expert
V2.0

PLC 1 M241
EX-1121 1 EtherNet/IP adapter

EX-200H 1 Digital quantity input
module

EX-300H 1 Digital output module
EX-4014 1 Analog input module
EX-5014 1 Analog output module

3. Set the IP address

For details about how to set the IP address, see 6.3.6 SETTING the IPAddress of the EX-1121 Adapter.

4. Install the EDS file

On the menu bar, choose Tools > Device Repository. In the device Repository window,
choose Install, as shown in Figure 5-7-2. In the EDS folder, select EX-1121_V1.1 and confirm the
installation.

file:///C:/Users/一世安/Desktop/总%20德克威尔EX卡片式远程IO用户手册.docx
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Figure 5-8-2 Installing the EDS file

5. New project and equipment configuration

Start Machine Expert V2.0, create a project, right-click "EtherNET_1" in the device tree,
and choose "Add Device", as shown in Figure 5-8-3.

Choose Protocol Manager > Industrial Ethernet Manager in the Add Device window, as
shown in Figure 5-8-4. Right-click "_(Industrial Ethernet Manager)" > Add Device in the device
window. Select DECOWELLAUTOMATION CO.,LTD for the supplier and ex-1121 in the
equipment catalog, as shown in Figure 5-8-5.
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Figure 5-8-3 Adding devices

Figure 5-8-4 Adding industrial Ethernet manager
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Figure 5-8-5 Adding ex-1121

To configure ex-1121 parameters, double-click EX-1121 in the device tree, and set the IP
address to a fixed IP address, as shown in Figure 5-8-6.

Figure 5-8-6 Configuring the IP address

Number of bytes occupied by computing modules:

Table 5-8-2 Number of bytes occupied by modules
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The module
type

Quantity Input/output
type

Occupied bytes

EX-2xx8 1 Input (T- >O) 2

EX-2xxH 1 Input (T- >O) 2
EX-2xxS 1 Input (T- >O) 4
EX-3xx8 1 Output (O- >T) 2
EX-3xxH 1 Output (O- >T) 2
EX-3xxS 1 Output (O- >T) 4
EX-4xx4 1 Input (T- >O) 8
EX-4xx8 1 Input (T- >O) 16
EX-5xx4 1 Output (O- >T) 8
EX-5xx8 1 Output (O- >T) 16

To configure connection parameters, double-click the default connection parameters, and set
the output bytes (O- >T) to 10 bytes and the input bytes (T- >O) to 10 bytes in the edit connection
window, as shown in Figure 5-8-7. View THE IO address mapping, as shown in Figure 5-8-8.

Figure 5-8-7 Configuring the input and output byte sizes

Figure 5-8-8 IO address mapping
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The physical address assignment corresponding to the actual module in the case:

Note: In actual hardware, the number of I/O modules configured for the EX-1121 adapter is the
same as that of the model, but the sequence of the MODULES is different, and the physical address
assignment for the modules is different, as shown in Figure 5-8-9, 5-8-10, and 5-8-11.

Adapter

Figure 5-7-9 I/O sorting and address assignment #1(application in case)

Adapter

Figure 5-7-10 I/O sorting and address assignment #2

Adapter

Figure 5-7-11 I/O sorting and address assignment #3

Note: the 8-channel digital input/output module occupies one word. The 8-channel module address is
used in the corresponding physical address

Low bytes correspond to 8 bits.

In EtherNet/IP I/O mapping will always update variable to choose "enable 2 (always in the bus cycle
task)", and download the program to PLC, and monitor the PLC running status and I/O mapping address.

5.8.2 Connection and Configuration between CODESYS and EX-1121

Note:

(1) The EX-1121 has two modes: special mode and normal mode. The special mode can only be used with
Keens CPU, and the factory default is normal mode.
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② The ex-1121 works in BOOTP mode by default and does not have an IP address.For details about how to set
the IP address, see 6.3.6 SETTING the IPAddress of the EX-1121 Adapter.

③ In common mode, the input and output bytes of communication between THE IO module and EtherNet/IP
are configured on the right of ex-1121

If the ex-1121 has only input or output modules on the right, the output (O-->T) byte length is set to 1Byte
or the input (T- >O) byte length is set to 1Byte. If neither I/O module is available, the input (T- >O) byte length
and output (O- >T) byte length are set to 1Byte.

The hardware
configuration

Input (T- >O)

bytes

Output (O- >T)

bytes

EX-1121 1 1
EX-1121
EX-200H 2 1

EX-1121
EX-300H 1 2

EX-1121
EX-200H
EX-300H

2 2

1. Communication connection diagram, as shown in Figure 5-8-12

Controller
Programming computer

Adapter

Figure 5-8-12 Communication connection diagram

2. Table 5-8-3 shows the hardware configuration

Table 5-8-3 Hardware configuration table

hardware Quantity note

Computer programming 1 Install the CODESYS
SP16

The controller 1

file:///C:/Users/一世安/Desktop/总%20德克威尔EX卡片式远程IO用户手册.docx
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EX-1121 1 EtherNet/IP adapter

EX-200H 1 Digital quantity input
module

EX-300H 1 Digital output module
EX-4014 1 Analog input module
EX-5014 1 Analog output module

3. Set the IP address

For details about how to set the IP address, see 6.3.6 SETTING the IPAddress of the EX-1121 Adapter.

4. Install the EDS file

On the menu bar, choose Tools > Device Repository. In the device repository window, choose
Install, as shown in Figure 5-8-13. In the EDS folder, select EX-1121_V1.1 and confirm the
installation.

Figure 5-8-13 Installing the EDS file

5. New project and equipment configuration

Open CODESYS SP16, create a project, right-click Device in the Device tree, and choose
Add Device. In the add Device window, choose Ethernet, as shown in Figure 5-8-14.

Right-click Ethernet in the device tree and choose Add Device. In the add Device window,
choose Ethernet /IP Scanner, as shown in Figure 5-8-15.

file:///C:/Users/一世安/Desktop/总%20德克威尔EX卡片式远程IO用户手册.docx
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Figure 5-8-14 Adding an Ethernet adapter

Figure 5-8-15 Adding the EthernetIP scanner

To configure the network adapter, double-click Ethernet in the device tree and select the
network adapter to communicate with Ethernet /IP slave, as shown in Figure 5-8-16.
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Figure 5-8-16 Configuring the network adapter for the Ethernet adapter

Right-click EtherNet_IP_Scanner in the device tree and choose Add Device. In the add
device window, select EX-1121, as shown in Figure 5-8-17.

Figure 5-7-17 Adding the EX-1121 adapter

To configure the IP address of the EX-1121 adapter, double-click EX_1121 in the device tree,
and enter the IP address (the IP address must be the same as that of the actual module), as shown
in Figure 5-8-18.



EX Series Card I/O

Email:contact@welllinkio.com 183

Figure 5-8-18 Configuring the IP address of the EX-1121 adapter

Number of bytes occupied by computing modules:

Table 5-8-4 Number of bytes occupied by modules

The module
type

Quantity Input/output
type

Occupied bytes

EX-2xx8 1 Input (T- >O) 2

EX-2xxH 1 Input (T- >O) 2
EX-2xxS 1 Input (T- >O) 4
EX-3xx8 1 Output (O- >T) 2
EX-3xxH 1 Output (O- >T) 2
EX-3xxS 1 Output (O- >T) 4
EX-4xx4 1 Input (T- >O) 8
EX-4xx8 1 Input (T- >O) 16
EX-5xx4 1 Output (O- >T) 8
EX-5xx8 1 Output (O- >T) 16

Set the input and output bytes of the I/O module of the EX-1121 adapter (you need to set the
input and output bytes based on the actual NUMBER of I/O modules to ensure normal
communication), as shown in Figure 5-8-19. Then view the I/O mapping of EtherNet/IP
communication, as shown in Figure 5-8-20.
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Figure 5-8-19 Configuring the size of input and output bytes

Figure 5-8-20 IO address mapping

The physical address assignment corresponding to the actual module in the case:

Note: In actual hardware, the number of I/O modules configured for the EX-1121 adapter is the
same as that of the model, but the sequence of the MODULES is different, and the physical address
assignment for the modules is different, as shown in Figure 5-8-21, 5-8-22, and 5-8-23.

Adapter

Figure 5-8-21 I/O sorting and address assignment #1(case application)
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Adapter

Figure 5-8-22 I/O sorting and address assignment #2

Adapter

Figure 5-8-23 I/O sorting and address assignment #3

Note: the 8-channel digital input/output module occupies one word. The 8-channel module address is
used in the corresponding physical address

Low bytes correspond to 8 bits.

In EtherNet/IP I/O mapping will always update variable to choose "enable 2 (always in the bus cycle
task)", and download the program to PLC, and monitor the PLC running status and I/O mapping address.

5.8.3 Connection and Configuration between Sysmac Studio and EX-1121

Note:

Note:

(1) The EX-1121 has two modes: special mode and normal mode. The special mode can only be used with
Keens CPU, and the factory default is normal mode.

② The ex-1121 works in BOOTP mode by default and does not have an IP address.For details about how to set
the IP address, see 6.3.6 SETTING the IPAddress of the EX-1121 Adapter.

③ In common mode, the input and output bytes of communication between THE IO module and EtherNet/IP
are configured on the right of ex-1121

If the ex-1121 has only input or output modules on the right, the output (O-->T) byte length is set to 1Byte
or the input (T- >O) byte length is set to 1Byte. If neither I/O module is available, the input (T- >O) byte length
and output (O- >T) byte length are set to 1Byte.

The hardware
configuration

Input (T- >O)

bytes

Output (O- >T)

bytes

EX-1121 1 1

file:///C:/Users/一世安/Desktop/总%20德克威尔EX卡片式远程IO用户手册.docx
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EX-1121
EX-200H 2 1

EX-1121
EX-300H

1 2

EX-1121
EX-200H
EX-300H

2 2

1. Communication connection diagram, as shown in Figure 5-8-24

Adapter

Programming computer

Figure 5-8-24 Communication connection diagram

2. Table 5-8-5 shows the hardware configuration

Table 5-8-5 Hardware configuration table

hardware Quantity Note

Computer programming 1 Install the Sysmac Studio
NX1P2 1
EX-1121 1 EtherNet/IP adapter

EX-200H 1 Digital quantity input
module

EX-300H 1 Digital output module
EX-4014 1 Analog input module
EX-5014 1 Analog output module

3. Set the IP address

For details about how to set the IP address, see 6.3.6 SETTING the IPAddress of the EX-1121 Adapter.

4. New project and equipment configuration

Open the Sysmac Studio programming software creation project and configure the
EtherNet/IP port as a fixed IP address (the same as the ACTUAL PLC port IP address), as shown
in Figure 5-8-25.

file:///C:/Users/一世安/Desktop/总%20德克威尔EX卡片式远程IO用户手册.docx
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Figure 5-8-25 EtherNet/IP port Settings

Create all variables, and create input and output variables in global variables. The length of
the variables must be the same as the length of input and output bytes in the actual module, as
shown in Figure 5-8-26.

Number of bytes occupied by computing modules:

Table 5-8-6 Number of bytes occupied by modules

The module
type Quantity Input/output

type Occupied bytes

EX-2xx8 1 Input (T- >O) 2

EX-2xxH 1 Input (T- >O) 2
EX-2xxS 1 Input (T- >O) 4
EX-3xx8 1 Output (O- >T) 2
EX-3xxH 1 Output (O- >T) 2
EX-3xxS 1 Output (O- >T) 4
EX-4xx4 1 Input (T- >O) 8
EX-4xx8 1 Input (T- >O) 16
EX-5xx4 1 Output (O- >T) 8
EX-5xx8 1 Output (O- >T) 16
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Figure 5-8-26 Creating global variables

On the menu bar, choose Tools > EtherNet/IP Connection Settings. In the EtherNet/IP list
window, double-click the node address to open the EtherNet/IP port connection Settings window,
as shown in Figure 5-8-27.

Figure 5-8-27 Opening the connection Settings window for built-in EtherNet/IP port Settings

Register variables. In the built-in EtherNet/IP port Settings connection Settings window,
select "Label Groups" window and click "Register All" to register the newly created global
variables, as shown in Figure 5-8-28.
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Figure 5-8-28 Registry variables

Install the EDS file, right-click in the blank area of the toolbox on the right of the connection
setting window of the built-in EtherNet/IP port, and choose Show EDS Library, as shown in
Figure 5-8-29.In the EDS library window, click Install to open the EDS file to be installed, as
shown in Figure 5-8-30.

Figure 5-8-29 shows the EDS library



EX Series Card I/O

Email:contact@welllinkio.com 190

Figure 5-8-30 Installing the EDS file

To add devices to be communicated with and set parameters, select "Add Target Device" in
the toolbox, as shown in Figure 5-8-31. Fill in the IP address of EtherNet/IP slave, slave model,
and revised version, and click "Add" in the lower left corner of the motor.

Figure 5-7-31 Adding a target device

Drag the target device 192.168.1.33 EX-1121 version 1 from the toolbox to the connection,
as shown in Figure 5-8-32.

Set the target device parameters. The input target variable of EX-1121 is 100, the output
target variable is 101, the input and output bytes are 10, and the starting variable is the global
variable registered, as shown in Figure 5-8-33.

Switch PLC to online, switch PLC to programming mode, and then select "Send to
Controller", as shown in FIG. 5-8-34;

Transfer PLC online, and then download the program into PLC. IO module sequencing
corresponds to the actual address, as shown in Figure 5-8-35 and 5-8-36.
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Figure 5-8-32 Adding a connected device

Figure 5-8-33 Setting target device parameters

Figure 5-8-34 Transferring the EtherNet/IP configuration to the controller

Channel/mo

dule

EX-1121 EX-200H EX-300H EX-4014 EX-5014

Channel 0 - Input[0][l] Output[0][l] Input[2] [3] Output [2][3]

Channel 1 - - - Input[4] [5] Output[4][5]
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Channel 2 - - - Input[6][7] Output[6] [7]

Channel 3 - - - Input[8][9] Output[8][9]

Figure 5-8-35 Correspondence between IO module sequencing and actual address (application in
case)

Channel/mo

dule

EX-1121 EX-4014 EX-5014 EX-200H EX-300H

Channel 0 - Input[0][l] Output[0][l] Input[8] [9] Outputf[8][9]

Channel 1 - Input[2] [3] Output[4][5] - -

Channel 2 - Input[4] [5] Output[6] [7] - -

Channel 3 - Input[6][7] Output[8][9] - -

Figure 5-8-36 Mapping between I/O module sequencing and actual addresses

5.8.4 Connection and Configuration between RSLogix 5000 and Ex-1121

Note:

(1) The EX-1121 has two modes: special mode and normal mode. The special mode can only be used with
Keens CPU, and the factory default is normal mode.

② The ex-1121 works in BOOTP mode by default and does not have an IP address.For details about how to set
the IP address, see 6.3.6 SETTING the IPAddress of the EX-1121 Adapter.

③ In common mode, the input and output bytes of communication between THE IO module and EtherNet/IP
are configured on the right of ex-1121

If the ex-1121 has only input or output modules on the right, the output (O-->T) byte length is set to 1Byte
or the input (T- >O) byte length is set to 1Byte. If neither I/O module is available, the input (T- >O) byte length
and output (O- >T) byte length are set to 1Byte.

The hardware
configuration

Input (T- >O)

bytes

Output (O- >T)

bytes

EX-1121 1 1
EX-1121
EX-200H

2 1

EX-1121
EX-300H 1 2

EX-1121
EX-200H
EX-300H

2 2
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1. Communication connection diagram, as shown in Figure 5-8-37

Programming computer

Adapter

Figure 5-8-37 Communication connection diagram

2. Table 5-8-7 shows the hardware configuration

Table 5-8-7 Hardware configuration table

hardware Quantity note

Computer programming 1 Install RSLogix 5000
PLC 1 1769-L23E-QB1

EX-1121 1 EtherNet/IP adapter

EX-200H 1 Digital quantity input
module

EX-300H 1 Analog output module
EX-4014 1 Analog input module
EX-5014 1 Analog output module

3. Set the IP address

For details about how to set the IP address, see 6.3.6 SETTING the IPAddress of the EX-1121 Adapter.

4. Install the EDS file

On the menu bar, choose Tools > EDS Hardware Installation Tool, as shown in Figure 5-8-38.
In the EDS installation window, select the specified folder, as shown in Figure 5-8-39.
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Figure 5-8-38 Installing the EDS file

Figure 5-8-39 Selecting the EDS folder path

5. New project and equipment configuration

Open RSLogix 5000, select a new project, and select the corresponding CPU and version, as
shown in Figure 5-8-40.
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FIG. 5-8-40 New construction project

Configuration EtherNet/IP communication, in Controller Manager, select EtherNet and right
click New Module, as shown in Figure 5-8-41.
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Figure 5-8-41 Creating a Module

Add IO module, select DECOWELL in filter, and select the actual IO module model, as
shown in Figure 5-8-42.

Figure 5-8-42 Selecting the IO module
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Configure the module name and IP address. The IP address must be the same as the actual IP
address. Otherwise, the communication fails, as shown in Figure 5-8-43.

Protocol Port Configuration Network

Figure 5-8-43 Edit module IP and name

In the New Module window, select Change to set the INPUT and output bytes of the EX-1121
(the number of bytes must be the same as the actual I/O Module; otherwise, the COMMUNICATION
fails), as shown in Figure 5-8-44.

Figure 5-8-44 Configuration module input and output bytes

Number of bytes occupied by computing modules:

Table 5-8-8 Number of bytes occupied by modules

The module
type Quantity Input/output

type Occupied bytes
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EX-2xx8 1 Input (T- >O) 2

EX-2xxH 1 Input (T- >O) 2
EX-2xxS 1 Input (T- >O) 4
EX-3xx8 1 Output (O- >T) 2
EX-3xxH 1 Output (O- >T) 2
EX-3xxS 1 Output (O- >T) 4
EX-4xx4 1 Input (T- >O) 8
EX-4xx8 1 Input (T- >O) 16
EX-5xx4 1 Output (O- >T) 8
EX-5xx8 1 Output (O- >T) 16

Choose to communicate with the online PLC and download the program, choose
"Communication" > "Activity" from the menu bar, select the online CPU, as shown in Figure
5-8-45, and download the program into the PLC, as shown in Figure 5-8-46.

Figure 5-8-45 Choosing to communicate with online PLC
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Figure 5-8-46 Program downloaded into PLC

Monitor whether the communication is normal, bring the CPU online, and monitor whether
the communication between EX-1121 and PLC is normal, as shown in Figure 5-8-47.
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Figure 5-8-47 Monitoring module running status

5.8.5 Connection and Configuration between KV STUDIO and EX-1121

Note:

(1) The EX-1121 has two modes: special mode and normal mode. The special mode can only be used with
Keens CPU, and the factory default is normal mode.

② The ex-1121 works in BOOTP mode by default and does not have an IP address.For details about how to set
the IP address, see 6.3.6 SETTING the IPAddress of the EX-1121 Adapter.

③ In common mode, the input and output bytes of communication between THE IO module and EtherNet/IP
are configured on the right of ex-1121

If the ex-1121 has only input or output modules on the right, the output (O-->T) byte length is set to 1Byte
or the input (T- >O) byte length is set to 1Byte. If neither I/O module is available, the input (T- >O) byte length
and output (O- >T) byte length are set to 1Byte.

file:///C:/Users/一世安/Desktop/总%20德克威尔EX卡片式远程IO用户手册.docx
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The hardware
configuration

Input (T- >O)

bytes

Output (O- >T)

bytes

EX-1121 1 1
EX-1121
EX-200H 2 1

EX-1121
EX-300H 1 2

EX-1121
EX-200H
EX-300H

2 2

1. Communication connection diagram, as shown in Figure 5-8-48

Programming computer

Adapter

FIG. 5-8-48 Communication connection diagram

2. Table 5-8-9 shows the hardware configuration

Table 5-8-9 Hardware configuration table

hardware Quantity note

Computer programming 1 Install the KV STUDIO
PLC 1 KV-7500

EX-1121 1 EtherNet/IP adapter

EX-200H 1 Digital quantity input
module

EX-300H 1 Analog output module
EX-4014 1 Analog input module
EX-5014 1 Analog output module

3. Set the IP address

For details about how to set the IP address, see 6.3.6 SETTING the IPAddress of the EX-1121 Adapter.

4. Copy XML files
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Copy all files in the "Keens Version" folder to the KV STUDIO software folder:

"C: \ ProgramData \ KEYENCE \ KVS11G_Trial \ KVS \ EIP_Eds"

5. New project and equipment configuration

Open KV STUDIO software, create a new project, and double-click "EtherNet/IP" in the
project device tree to open the EtehrNET/IP Settings window, as shown in Figure 5-8-49.

Figure 5-8-49 Opening the EtherNet/IP Settings window

Install the EDS file. On the menu bar of the EtherNet/IP configuration window, choose EDS
File > Login. In the EDS folder, choose Common Version > EX-1121, as shown in Figure 5-8-50.

Figure 5-8-50 Installing the EDS file
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Set the ex-1121 adapter mode to special PLC mode (the factory default is common mode).
Right-click the blank area in the device Search option on the right and choose "Device Search", as
shown in Figure 5-8-51.

Add the scanned devices to the scan list. Right-click the devices to be added and choose Add
to scan List, as shown in Figure 5-8-52.

For transmission adapter Settings, right-click "EX-1121" in the device list and choose
"Transmission Adapter Settings", as shown in Figure 5-8-53.

In the transfer adapter setting window, change the adapter No.100 setting value to "1: Special
PLC" and write the adapter, as shown in Figure 5-8-54. After the writing is complete, the
EX-1121 must be powered off and restarted.

In the EtherNet/IP Settings window, select KV-7500 and right click "Auto Configuration" to
read ex-1121 again, as shown in Figure 5-8-55.

Figure 5-8-51 Device search
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Figure 5-8-52 Adding devices to the scan list

Figure 5-8-53 Adapter transfer Settings
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Figure 5-8-54 Write adapter

Figure 5-8-55 Re-reading ex-1121
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Download the program into PLC and choose "Monitoring/Simulator" > "PLC Transmission" from
the menu bar. After downloading, switch PLC to monitoring mode to monitor the communication
status between PLC and EX-1121, as shown in Figure 5-8-56.

Figure 5-8-56 Monitoring the communication between PLC and EX-1121

5.9 Connection between Ex-1112 and PLC

5.9.1 Connection and Configuration between TIA Portal and EX-1112

1. Communication connection diagram, as shown in Figure 5-9-1.

Programming computer

Adapter

Figure 5-9-1 Communication connection diagram

2. Table 5-9-1 shows the hardware configuration

Table 5-9-1 Hardware configuration table

hardware Quantity note

Computer programming 1 Install TIA Portal V16
The controller 1 S7-1214C
EX-1112 1 PROFINET adapter
EX-4014 1 Analog input module
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EX-5014 1 Analog output module

EX-200H 1 Digital quantity input
module

EX-300H 1 Digital output module
Ethernet cable A number of

3. Install the GSD file

Open TIA Portal V16 and choose Options > Support Device Description File (GSD) from the
menu bar, as shown in Figure 5-9-2.

Figure 5-9-2 Installing GSD files

4. New project and equipment configuration

Open TIA Portal V16, select a new project and configure it, as shown in Figure 5-9-3.
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Figure 5-9-3 New construction project

To configure the device, expand the hardware directory in the network view and select the
adapter, as shown in Figure 5-9-4. Double-click the adapter to access the CONFIGURATION I/O
module in the device view, as shown in Figure 5-9-5.

Figure 5-9-4 Configuration equipment

Figure 5-9-5 Configuration I/O module

To assign controllers to I/OS in the network view, click Unassigned in the I/O module and
select PLC_1.PROFINET interface _1, as shown in Figure 5-9-6.
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Figure 5-9-6 Assigning IO controllers

Set the IP address of the I/O module. In the device view, double-click the module to go to the
properties view, as shown in Figure 5-9-7.

Figure 5-9-7 Assigning IP addresses

To assign a device name to a remote I/O module, right-click the module and choose Assign
Device Name, as shown in Figure 5-9-8. Select the interface type, update the interface list, and
assign the device name, as shown in Figure 5-9-9.
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Figure 5-9-8 Assigning device names Figure 5-9-9 Writing device names

Modify the input channel filtering parameters of ex-2XXX series modules. In the overview
view of the device view, right-click the input module and set the input channel filtering time (the
default value is 3ms, and the range can be 0.5-10ms), as shown in Figure 5-9-10.

Figure 5-9-10 Configuring filtering parameters of the input module

5. Program download and equipment monitoring

Select all devices in the network view and download, as shown in Figure 5-9-11. After
downloading the program, start the CPU and switch to online monitoring for normal
communication, as shown in Figure 5-9-12.
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Figure 5-9-11 Program download

Figure 5-9-12 Equipment monitoring

5.9.2 Connection and Configuration between Step7 smart devices and EX-1112

1. Communication connection diagram, as shown in Figure 5-9-13.
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Programming computer

Adapter

Figure 5-9-13 Communication connection diagram

2. Table 5-9-2 shows the hardware configuration

Table 5-9-2 Hardware configuration table

hardware Quantity note

Computer programming 1 Install STEP7 - MicroWIN
SMART

The controller 1 CPU ST40(DC/DC/DC)
EX-1112 1 PROFINET adapter
EX-4014 1 Analog input module
EX-5014 1 Analog output module

EX-200H 1 Digital quantity input
module

EX-300H 1 Digital output module
Ethernet cable A number of

3. Install the GSD file

Open Step 7-Microwin SMART, and choose GSDMLManagement from the menu bar, as
shown in Figure 5-9-14.
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Figure 5-9-14 Installing GSD files

4. Assign the device name

On the menu bar, choose Tools > Find PROFINET Device, select the network adapter
connected to the module in the window and find the device, select the module in the network and
edit its device name, as shown in Figure 5-9-15.

Note:

① When you select a NIC, two options are displayed for the same NIC, as shown in the following
figure. Select the NIC without Auto.

(2) After the device name is assigned, note that the device name must be the same as the assigned
name when configuring the IO module; otherwise, PLC cannot communicate with the IO module
normally.
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Figure 5-9-15 Assigning device names

5. New project and equipment configuration

On the menu bar, choose Tools > PROFINET, select the PLC role as the controller, as shown
in Figure 5-9-16, add the adapter, assign the device name (the same as that assigned in Step 4)
and IP address, as shown in Figure 5-9-17, add the IO module, as shown in Figure 5-9-18, and
select Generate.
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Figure 5-9-16 Selecting PLC roles

Figure 5-9-17 Adding an adapter
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Figure 5-9-18 Adding an I/O module

Modify the filtering parameters of the input channel of ex-2XXX series modules. In
PROFINET network, select the DI module to view its filtering time (the default is 3ms, and the
range can be set to 0.5-10ms), as shown in Figure 5-9-19.

Figure 5-9-19 Configuring input module filtering parameters

6. Program download

Choose "PLC" > "Download" in the menu bar, and select "Find CPU" in the communication
window, select the PLC that needs to download the program, and download the program.



EX Series Card I/O

Email:contact@welllinkio.com 217

Note: For PROFINET communication using STEP 7-Microwin SMART configuration 200 SMART, the
CPU firmware version of PLC must be ≥V2.4. For firmware = V2.3, you can directly upgrade the
firmware online. For firmware < 2.3, you must update the firmware with a memory card in the CPU.

5.9.3 Connection and Configuration between Step7 and Ex-1112

1. Communication connection diagram, as shown in Figure 5-9-20.

Programming computer

Adapter

Figure 5-9-20 Communication connection diagram

2. Table 5-9-3 shows the hardware configuration

Table 5-9-3 Hardware configuration table

hardware Quantity note

Computer programming 1 Install Step7 V5.6
The controller 1 315-2 PN/DP
EX-1112 1 PROFINET adapter
EX-4014 1 Analog input module
EX-5014 1 Analog output module

EX-200H 1 Digital quantity input
module

EX-300H 1 Digital output module
Ethernet cable A number of

3. Install the GSD file

After the new project is created, click "SIMATIC300", double-click "Hardware", in the HW
Config window, choose "Options" > "Install GSD file" from the menu bar, as shown in Figure
5-9-21.
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Figure 5-9-21 Installing GSD files

3. New project and equipment configuration

Open SIMATIC Manager, choose New Project from the menu bar, name the project, and
select a path to save the project, as shown in Figure 5-9-22.
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Figure 5-9-22 New construction project

Add 300 sites in the project, as shown in Figure 5-8-23.Click the newly added 300 site and
select "Hardware" to enter the HW Config configuration interface, as shown in Figure
5-9-24.Add RACK Reil for RACK 300, as shown in Figure 5-9-25.To add a CPU module, click
HW Config, select CPU315-2 PN/DP VERSION V2.6 of CPU-300 in the right pane, and drag the
CPU module to slot 2 of the rack, as shown in Figure 5-9-26.In the Ethernet interface properties
interface, you can use other IP addresses as required, here use the default IP address and subnet
mask, and select the New button, create a new subnet Ethernet (1) click OK, as shown in Figure
5-9-27.
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Figure 5-9-23 Adding 300 sites

Figure 5-9-24 The HW Config page is displayed
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Figure 5-9-25 Adding rack Reil

Figure 5-9-26 Adding a CPU module to the rack

Figure 5-9-27 Adding an Ethernet subnet
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On Ethernet (1), configure the I/O device station. On the right, select EX-1112 and drag it under
the Ethernet (1) subnet, as shown in Figure 5-9-28.

Figure 5-9-28 Adding IO to an Ethernet (1) subnet

Add an I/O module, expand the ex-1110 on the right, and drag the EX-4014 and EX-5014 to
the lower slot on the left, as shown in Figure 5-9-29.

Figure 5-9-29 Adding an I/O module

To change the IP address of the I/O device station, double-click ex-1112 on the subnet, and
choose Ethernet in the Ethernet property window. You can change the IP address in the Ethernet
property window, as shown in Figure 5-9-30.
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Figure 5-9-30 Changing the MODULE IP address

Set the device name for the I/O module, select the subnet icon, choose PLC on the menu bar,
Ethernet > Assign Device Name, as shown in Figure 5-9-31. In the Assign Device name window,
select the name to be assigned, and press Ok.
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Figure 5-9-31 Assigning device names

To check whether the name is assigned successfully, select the subnet icon, choose PLC on
the menu bar, and Ethernet > Verify Device Name, as shown in Figure 5-9-32.

Figure 5-9-32 Verifying the device name



EX Series Card I/O

Email:contact@welllinkio.com 225

Modify the filtering parameters of the input channel of the ex-2xxx series modules. In the
ex-1112 slot, double-click the DI module to view the filtering time (3ms by default, and the range
can be 0.5-10ms), as shown in figure 5-9-33.

Figure 5-9-33 Configuring input module filtering parameters

6 Module Application

6.1 Module Configuration

6.1.1 How many I/O modules can an adapter support

The number of modules an adapter can support depends on the device master protocol (for
example, CC-Link), the maximum number of I/O extensions of the adapter (the maximum
number of I/O extensions of the adapter is 32 IO), the number of input and output bytes of the
adapter (for example, PROFINET input and output bytes are 340 bytes, EtherCAT input and
output bytes are 1024 bytes), Table 6-1 lists the maximum input/output bytes of an adapter. Table
6-2 lists the maximum input/output bytes of an I/O module

Table 6-1 Maximum number of input and output bytes of an adapter

The adapter
Maximum

Maximum
number of input

Maximum
number of
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I/O quantity bytes output bytes

EtherCAT 32 1024 1024
PROFINET 32 340 340
DeviceNet 32 - -
CC-Link 32 128 128
CANopen 32 512 512

PROFIBUS-DP 32 244 244
Modbus RTU 32 512 512
EtherNet/IP 32 504 504

Table 6-2 I/O module input/output bytes

Module type
Number of
input bytes

Output
bytes

8DI 1 -
16DI 2 -
32DI 4 -
4AI 8 -
8AI 16 -
8DO - 1
16DO - 2
32DO - 4
4AO - 8
8DO - 16
TC 8 -
RTD 8 -

The encoder 9 5
Positioning
module 5 18
RS232 66 66
RS485 66 66

 To calculate how many IO modules an adapter can carry, the following two equations
must be met:

The NUMBER of I/O modules configured with the adapter is less than or equal to 32.

The number of INPUT and output bytes of the I/O module with the adapter is less than or
equal to the number of input and output bytes specified by the adapter.

 For example, cc-link supports a maximum of 4 x (32DI+32DO+4AI+4AO) for a single
adapter (128 bytes in input / 128 bytes in output).

Note:
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(1) The greater the sum of the input and output bytes of the I/O module, the longer the communication
period between the adapter and the I/O module.

(2) Terminal modules and power modules are not counted in the I/O module count.

6.1.2 Adapter Parameter Setting Problems

 EtherCAT adapter

Current versions of the EtherCAT coupler do not support setting the slave address via dip.

 PROFINET adapter

Assign IP addresses and names, such as TIA Portal and Step7, to the host computer.

 PROFIBUS DP adapter

The communication address is assigned by dip switch, and the baud rate is set by the host
computer, such as TIA Portal and Step7.

 CC - Link adapters

Assigns address and baud rate by DIP switch.

 DeviceNet adapter

Assigns address and baud rate by DIP switch.

 CANopen adapter

Assigns address and baud rate by DIP switch.

 Modbus RTU adapter

Modify communication parameters (such as data bits and parity check) by software, and
assign communication address and baud rate by DIP switch.

6.1.3 Maximum output current of the digital output module

 8 do module

The maximum output of a single channel is 500mA. When eight channels are simultaneously
output, the total output current of the eight channels is 2A.

 16 do module

The maximum output of a single channel is 500mA. When 16 channels are simultaneously
output, the total output current of the 16 channels is 4A.

 32 do module

The maximum output of a single channel is 500mA. When 32 channels output at the same
time, the total output current of 32 channels is 8A.
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 8 RELAYmodule

Single channel 2A, DC30V/0.5A, AC125V.

6.1.4 Differences between system Power Supplies and I/O Power supplies

 System power supply: provides power for the communication of the EXTENSION I/O
module.

 I/O power supply: Supplies power to the output channels of the expansion I/O module, such
as digital output and analog output.

6.1.5 Can the output module control the inductive load

 Yes, all transistor digital output modules have continuous diode protection.

6.1.6 DeviceNet Adapter Networking

 The communication terminal of the adapter must be connected to an independent DC24V
power supply.

 You need to configure two terminal resistors, one is the two terminals of the network, the
specification is 121 ω, 1/4W.

6.1.7 Whether the Thermal resistance/thermocouple module supports filtering configuration

 Yes. You can configure different filtering levels (0-40) by parameter. The default value is 10.

6.1.8 Analog input module 2-wire / 3-wire / 4-wire connection method

Figure 6-1-1 Analog input 2/3/4 line wiring

6.1.9 EX-1120/EX-1121 Output Hold Settings

 Schneider Machine Expert V2.0 software is configured with EX-1120 output IO hold, as
shown in Figure 6-1-2.Clear indicates that the output is not held, and Hold indicates that the
output is held.



EX Series Card I/O

Email:contact@welllinkio.com 229

Figure 6-1-2 Schneider programming software configuration output hold

 EX-1120 output I/O hold is configured in CODESYS programming software, as shown in
Figure 6-1-3.

Clear indicates that the output is not held, and Hold indicates that the output is held

Figure 6-1-3 CODESYS programming software configuration output retention
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 Ex-1120 output IO hold is configured by Omron Sysmac Studio programming software, as
shown in Figure 6-1-4 and 6-1-5.Clear indicates that the output is not held, and Hold indicates
that the output is held.

Figure 6-1-4 Editing ex-1120

Figure 6-1-5 Omron Sysmac Studio programming software configuration output hold

 The PROGRAMMING software of KV STUDIO is configured with EX-1120 output IO
retention, as shown in Figure 6-1-6.Clear indicates that the output is not held, and Hold
indicates that the output is held.
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KV STUDIO programming software configuration ex-1120 output hold

6.2 Common communication exceptions and exclusion methods

6.2.1 EtherCAT Communication is abnormal

 Figure 6-2-1 shows the troubleshooting process when the communication with OMron PLC
is abnormal.

EtherCAT
Communications
abnormal

Checking Module
Configuration

Whether to Write
Device Node Address

Whether to power off
and restart

Check the Network
Line

Figure 6-2-1 Troubleshooting process

 Ex-1100 adapter indicator

SYS indicator light

System light status instructions

Blinking at long intervals (1HZ) The system runs normally.

destroy The I/O module type does not match

1 shine 1 fade Communication with the I/O module fails

2 Flash 1 Off The I/O module fails to be configured

Blinking at short intervals (5HZ) I/O module missing
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6.2.2 PROFINET communication Is Abnormal

 Figure 6-2-2 shows the troubleshooting process when communication is abnormal.

PROFINET
Communications

abnormal

Checking Module
Configuration

Check IPAddress and
Device Name

Check the Network
Line

Figure 6-2-2 Troubleshooting process

 During module configuration, check whether the host configuration is consistent with the actual
hardware configuration.

 When assigning IP addresses, ensure that the IP addresses do not overlap with those of other devices
on the network.

 Before downloading the configuration, you must write the device name into the device. The device
name is unique and cannot coincide with other device names on the network.

6.2.3 DeviceNet Communication Is Abnormal

 Figure 6-2-3 shows the troubleshooting process when communication is abnormal.

DeviceNET
Communications

abnormal

Is the module
communication terminal
connected to the power

supply?

Check Dial
Parameter Settings

Check terminal
resistance on both
sides of the network

Check Input Output
Byte Settings

Check the Network
Line

Figure 6-2-3 Troubleshooting process

6.2.4 CC-link Communication is abnormal

 Figure 6-2-4 shows the troubleshooting process when communication is abnormal.

CC-link
Communications

abnormal

Checking Module
Configuration

Check Input Output
Byte Settings

Check the Network
Line

Figure 6-2-4 Troubleshooting process

6.2.5 Modbus RTU Communication Is Abnormal

 If the communication is abnormal, the troubleshooting process is shown in Figure 6-2-5

Modbus RTU
Communications

abnormal

Check whether
communication

parameters are consistent

Check the Network
Line

Figure 6-2-5 Troubleshooting process

6.2.6 EtherNet/IP Communication Is Abnormal

 Check for abnormality of Keens EtherNet/IP communication:
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EtherNET/IP
Communications

abnormal

Whether IP address
conflict

Configuration and
Actual Module
Model/Number

EX-1120 whether the
mode is set to 1

Mode configured to 1
requires power outage

and restart

Figure 6-2-6 Troubleshooting flowchart for Keens EtherNet/IP

 Fault diagnosis of EtherNet/IP based on CODESYS software platform (including Omron, Schneider,
Huichuan) communication:

EtherNET/IP
Communications

abnormal

Whether IP address
conflict

Configuration and
actual module byte size

Figure 6-2-6 Troubleshooting process for EtherNet/IP of other manufacturers
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6.3 Using Modules

6.3.1 Encoder Module

 In the encoder module, there are three signal types: differential, NPN and PNP, but the
modules are used in the same way. The input and output are shown in Table 6-3-1, and the
basic configuration process is shown in Figure 6-3-1.

Table 6-3-1 Input and output channels of the encoder module

No. Channel name Channel type Data type description

1 Set Initvalue Enable Output BOOL Setting the initial value

2 Z Phase Enable Output BOOL Z-phase enabler

3 Counting Direction Output BOOL Counter direction

4 Count Enable Output BOOL Count enabler

5 Latch Enable Output BOOL Lock-in enabler

6 Initial Count Value Output UDINT Initial count

7 Latch Signal Input BOOL Latch signal

8 Count Value Input UDINT count value

9 Latch Value Input UDINT Latch value

10 Temperature Alarm Input BOOL Temperature alarm

11 Voltage Alarm Input BOOL Voltage alarm

parameter
configuration

Count enabler Monitor

Latch signal

Latch value

count value

Lock-in enabler

Counter direction

Z-phase enabler

Setting the initial value

Figure 6-3-1 Basic configuration process

6.3.2 High-speed pulse output module

 In the high-speed pulse output module, there are three signal types: differential, NPN, and
PNP, but the modules are used in the same way. The input and output are shown in Table
6-3-2 and the basic configuration process is shown in Figure 6-3-2.
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Table 6-3-2 Input and output channels of high-speed pulse output module

No. Channel name Channel type Data type description

1 Direction Control Output BOOL Direction control

2 Inching Enable Output BOOL dot mode enabler

3 Inching Control Output BOOL Inching operation

4 Location Enable Output BOOL
Location mode enabler

Positioning operation

5 Location Control Output BOOL Emergency stop

6 Emergency Stop Enable Output BOOL Pulse direction

7 Direction Pulse Mode Output BOOL CW/CCWmode

8 CW/CCWMode Output BOOL Orthogonal mode

9 Orthogonal Mode Output BOOL
Positive and negative

orientation

10 Negative[0] Or Positive[1] Logic Output BOOL Slope start

11 Ramp Enable Output BOOL Initial pulse frequency

12 Start Pulse Frequency Output UDINT Pulse output frequency

13 Output Pulse Frequency Output UDINT Locating pulse number

14 Location Pulse Output UDINT Acceleration Time

15 Ramp Increase Time Output UINT Deceleration time

16 Ramp Decrease Time Output UINT
Locate the complete flag

bit

17 Location Finish Flag Input BOOT Operating status bit

18 Operation Status Flag Input BOOT
Pulse output feedback

number

19 Location Or Inching Pulse Feedback Input UDINT Temperature alarm

20 Temperature Alarm Input BOOL Voltage alarm

21 Voltage Alarm Input BOOL
Primary parameter is

invalid

22 Master Station Parameters Ilegality Input BOOL Pulse output fault

23 Pulse Output Failure Input BOOL Direction control

parameter
configuration Mode choice

Start running
Direction control

Monitor

Pulse mode

Acceleration/decelerati
on time

Pulse output frequency

Inching mode

Positioning mode

Inching operation

Positioning operation
Positioning pulse

number

Operating status bit

Pulse output feedback
number
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Figure 6-3-2 Basic configuration process

 Figure 6-3-3 shows the process for configuring the control mode

Direction pulse Acceleration/deceleratio
n time

Motor inversion

Pulse output feedback
number

dot mode enabler

Direction control dot operation

motor rotating

Figure 6-3-3 Dynamic mode configuration process

 Figure 6-3-4 shows the process for configuring the location control mode

Direction pulse Acceleration/decelerati
on time

Reverse operation Positive and negative
positioning direction

Pulse output frequency dot mode enabler

dot pulse number

positioning operation

positive running

Figure 6-3-4 Configuration of the positioning control mode

6.3.3 EX-6311/6301 Free communication module use

 There are four modes of module communication:

(1) Send-rev mode: trigger mode and receive data at character intervals.

② Send-send mode: trigger sending mode;

③ Rev-send mode: triggers the sending mode and receives data at character intervals.

④ Rev-rev mode: Receive data at character intervals.

 Table 6-3-3 lists the communication parameters

Table 6-3-3 Communication parameters

parameter name
Parameter
meaning

parameter

BaudRate Baud rate
1200/2400/4800/9600 (default) / 19.2 K / 38.4 K

/ 57.6 K / 115.2 K

Data Bits Data bits 5 bit /6 bit /7 bit /8 bit (default)
Parity Bits Check digit None Check (default)/parity check/even check
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Stop Bits Stop bit 1 bit (default) /2 bits

Interval Time
Automatic timing
sending function

Timing send interval from 50ms to 10s optional
(1s by default)

Comm Mode
Communication
mode selection

M/S (master/slave), default master mode

Note: Parameter Settings need to be configured before the module runs. For example, if you use
TwinCAT, set the parameters in Startup.In OMROM software, the corresponding module needs to be
found and set in the edit initialization parameter setting of the module.If no operation is required, use the
default value.

 Process data - Output data

The output data length is 66 bytes. The first two bytes are data length and control word
respectively, and the last 64 bytes are data bytes, as shown in Figure 6-3-5.

Data

length
Control

word Data

Figure 6-3-5 Process data - Output data

The data length and the meanings of single bits in the control words are shown in Table 6-3-4.

Table 6-3-4 Data length and control words

The
name of
the

The
length
of the

Bit
definition

The
length of
the data

1 byte -
The length of the data is N, and the maximum value of N
is 64

Control
word

1 byte

Bit0

TxE starts sending flags
When TxM =0, it is the trigger mode. At this time, only
when TxE changes from 0 to 1 (rising edge), a sending
is triggered.
Automatic send mode when TxM=1
In this case, only when TxE is 1, the module
automatically sends packets continuously according to
the Automatic sending Interval specified in the
configuration information.

Bit1
TxM sending mode
TxM=0: triggers the sending mode
TxM=1: automatic timing sending mode
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Bit2

Relen receives by length
Relen =0 Received by character interval: 3.5 consecutive
characters (with baud rate, number of characters, and
check whether or not) after a character is received
When the next character is not received, the packet is
considered to be closed
Beam.

Bit3 Channel 0:0
Bit4 keep
Bit5 keep
Bit6 Set_re forcibly waits for receiving

Bit7
Set_tr Forcibly sets the receive completion/send permit
status

Table 6-3-5 describes the Bit0 and Bit1 modes in the control word.

Table 6-3-5 Control word Bit0 and Bit1 modes

Bit1 state Bit0 state
Delivery
mode

instructions

0 The 0-1 Trigger mode Complete a send

0 0 Trigger mode Don't send

1 1
Automatic
mode

According to Auto Send Interval,
automatic continuous sending is enabled

1 0
Automatic
mode

Don't send

The mode definitions of Bit6 and Bit7 in the control words are shown in Table 6-3-6.

Table 6-3-6 Control word Bit6 and Bit7 mode definitions

Bit7 state
State of
Bit6

function

1 0
Set_tr: Force reok_TREn =1, so that RS485 is in the
receiving complete/sending allowed state

0 1
Set_re: Force REok_tren =0 to make RS485 in the waiting
for receiving state

1 1 No role
0 0 No role
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 Process data - Input data

The input data length is 66 bytes. The first two bytes are data length and communication status
respectively, and the last 64 bytes are data bytes, as shown in Figure 6-3-6.

Data

lengt

h

Communic

aton status Data

Figure 6-3-6 Process data - Input data

For example, if the received data is 04 01 01 02 03 04, the data length is 4 bytes. The
communication status is receiving completed or sending allowed. The received data is 01 02 03
04.

Table 6-3-7 shows the data length and the meaning of a single bit of the communication status
word.

Table 6-3-7 Data length and communication status words

name length
Bit

definition

The length of
the data

1 byte -
The length of the data is N, and the maximum value of N
is 64

Communication
status

1 byte

Bit0

Reok_tren Receiving completed or sending allowed
Reok_tren =1: The RS485/RS232 interface is in the
receiving complete/sending Allowed state.
Reok_tren =0: The RS485/RS232 interface is in waiting
state.

Bit1

Tr_ing is sending
Tr_ing =1: The RS485/RS232 interface is sending data.
Tr_ing =0: THE RS485/RS232 interface is not sending
data.

Bit2

Re_ing is receiving
Re_ing =1: The RS485/RS232 interface is receiving
data.
Re_ing =0: The RS485/RS232 interface is not receiving
data.

Bit3 keep
Bit4 keep
Bit5 keep
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Bit6 keep
Bit7 keep

The Bit0, Bit1, and Bit2 modes in the communication status word are defined as shown in Table
6-3-8.

Table 6-3-8 Definition of Bit0, Bit1 and Bit2 modes in the communication state word

Bit2 state Bit1 state Bit0 state function

0 0 1

RS485 is in the state of "receiving
completed/sending allowed". If TxE starts from
0 to 1, RS485 switches to D2D1D0=010, that is,
data in the output data area is sent to
RS485/RS232 equipment.

0 1 0
RS485/RS232 packets are being sent to the
RS485 device.

0 0 0
RS485/RS232 is in the waiting state, that is,
waiting to receive data packets from the
RS485/RS232 device.

1 0 0
RS485/RS232 receiving packets from the
RS485/RS232 device.

 Module operation mode

① Send_Rev mode :(trigger mode, receive at character intervals)

(1) The module is powered on (configuration information is in main mode by default), D2D1D0
of Status byte =001, and the RS485 interface is in receive completed/Send Allowed state.

(2) Control byte = 0x0801, trigger mode, start sending mark, according to character interval,
channel number 0,TxE start sending mark changes from 0 to 1, rising edge sends 8 bytes of data;

(3) D2D1D0=000 in status byte, the status word is 0, and the RS485 interface is in the "Waiting
for receiving" state.

(4) Module status STATUS D2D1D0 of BYTE is 001, and the RS485 port is in the receive
completed/Send Allowed state.

(5) The master station waits for D2D1D0 of Status byte =001 and the module is in the "receiving
completed/sending allowed" state before sending the next operation.

(6) Go to Step 1.

② send-send mode :(trigger sending mode)

(1) The module is powered on (configuration information is in main mode by default), D2D1D0
of Status byte =001, and the RS485 interface is in receive completed/Send Allowed state.
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(2) Control byte = 0x0801, trigger mode, start sending mark, according to character interval,
channel number 0,TxE start sending mark changes from 0 to 1, rising edge sends 8 bytes of data;

(3) D2D1D0=000 in status byte, the status word is 0, and the RS485 interface is in the "Waiting
for receiving" state.

(4) The master station detects the communication state word D2D1D0=000, and the strong
control word D7d6 =10, namely set_tr=1,

Set_re = 0;Make the bus bridge enter the state of "receiving completed/sending allowed", and the
communication status word D2D1D0=001.

(5) Master station recovery control word D7 D6=00;

(6) Go to Step 1.

③ rev-send mode :(Triggering the sending mode and sending at character intervals)

(1) The module is powered on (the configuration information is changed to slave mode), and the
communication status word D2D1D0=000, that is, reOK_TREn =0;Waiting for receiving state;

(2) When the RS485/RS232 interface finishes receiving packets, the communication status word
D2D1D0=001, namely reOK_TREn =1;Receiving completed/sending allowed status;

(3) master station start send TxE start send mark from 0 to 1, control word control byte = 0x0801,
trigger mode, according to character interval close, channel number 0,TxE start send mark from 0
to 1, rising edge send 8 bytes of data;

(4) D2D1D0=000 in status byte, the status word is 0, and the RS485 interface is in the waiting for
receiving state.

(5) Go to Step 1

④ rev-rev mode :(Receive at character intervals)

(1) The module is powered on (the configuration information is changed to slave mode), and the
communication status word D2D1D0=000, that is, reOK_TREn =0;Waiting for receiving status.

(2) When the RS485 interface finishes receiving packets, the communication status word
D2D1D0=001, that is, REOK_TREn =1;Receiving completed or sending allowed status.

(3) The master station detects the communication state word D2D1D0=001, and the strong
control word D7D6 =01, that is, set_tr=0,

Set_re =1, make RS485/RS232 enter "waiting for receiving" state;

(4) Master station recovery control word D7 D6=00;

 Figure 6-3-7 shows the process for using the EX-6301 with the serial port Debugging
Assistant.
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Configure ex-6301
parameters such as baud rate,
data bit, parity bit, and stop

bit

Configure serial debugging
assistant parameters (baud
rate, data bit, parity bit, stop

bit)

PLC sends data: -04 01 01 02
03 04

The serial assistant sends data:
04 01 01 02 03 04

The serial port receives the
following data :0102 03 04

Data received by PLC :04 01
01 02 03 04

Figure 6-3-7 Usage process

6.3.4 TIA Portal Configures ex-6321 modules

After ex-1110 is configured on the TIA Portal, add ex-6321 (Modbus RTU Master module) to
the slot, as shown in Figure 6-3-8.

Figure 6-3-8 Configuration of the EX-6321 module

To configure ex-6321 communications parameters, right-click module in the slot and choose
Properties to set communications parameters, as shown in Figure 6-3-9.
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Figure 6-3-9 Configuring ex-6321 communication parameters

Table 6-3-9 lists the configurable parameters of ex-6321, such as baud rate, parity check, stop
bit, and communication timeout

Table 6-3-9 Definitions of communication parameters

The
serial
number

parameter instructions
note

1 BaudRate Baud rate Users can choose standard baud rate
2 Data Bits Data bits Fixed for 8 bit
3 Patity Bits parity This parameter is configurable by default
4 Stop Bits Stop bit The default value is 1 bit

5
Reapons Timeout

Low
Timeout low

bytes

For example, if the communication
timeout is 1000ms, it is converted to
hexadecimal 0x03E8, whose decimal

value is 232

6
Reapons Timeout

High
Timeout high

byte

For example, if the communication
timeout is 1000ms, it is converted to

hexadecimal 0x03E8. The decimal value
of 03 is 03
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7 Char Pitch
Characters in

length
The default value is 5char, which is

configurable

EX-6321(Modbus RTU Master module) address assignment table in case 6-3-8, as shown in
Figure 6-3-9.

Output area (Q area)

No Address Description Note

1 Q1.0 Data sending
0 →1: data is sent

1 →0: sending is disabled

2 QW2 Modbus RTU Slave station 0-255

3 QW4 Modbus Fuction code
Supported Function

code :01/02/03/04/05/06/15/16
4 QW6 Slave station Depository Address 0-65535
5 QW8 The length of data read or written Length value: 1-4

6 QW10 The master station sends data #1

Valid only for register writing
7 QW12 The master sends data #2

8 QW14 The master sends data #3

9 QW16 The master sends data #4

input area (I area)

No Address Description Note
1 11.0 Send complete flag bit 0→1: Data is sent

2 11.1 Receive completion flag bit 0→1: Data is received

3 IW2

Modbus RTU returns from the

secondary address

Returns the slave address

4 IW4

Modbus RTU communication error

code from

0: The communication is normal

5 IW6 The station returns data #1

6 IW8 Return data #2 from the station

7 IW10 Return data #3 from the station

8 IW12 Return data #4 from the station

Figure 6-3-9 Address allocation table

For example, read Modbus RTU slave station #1 register 400001/40002/40003/40004:

QW2, QW4, QW6, and QW8 correspond to 01 03 00 04

Then set Q1.0 to TRUE

In IW6/IW8/IW10/IW12, you can view the data of register 40001/40002/40003/40004.
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For example, write data to Modbus RTU slave station #2 register 40010/40011/40012/40013
to 100, 3000, 80, 300 respectively:

QW2 QW4 QW6 QW8 QW10 QW12 QW14 QW16 The corresponding data is 01 16 00 04 100
3000 80 300

Then set Q1.0 to TRUE

Note: Q1.0 pin from 10, IW6/IW8/IW10/IW12 data will be automatically cleared

6.3.5 TwinCAT3 configuration EX-6321

After TwinCAT3 is enabled, configure ex-1100, and add ex-6321 to the slot, as shown in
Figure 6-3-10.

Figure 6-3-10 Configuration of the EX-6321 module

To configure ex-6321 communication parameters, double-click Box 1 (EX-1100) > StartUP,
right-click the blank area, and choose Add New Item. In the StartUP parameter window, select
EX-6321 to set communication parameters, as shown in Figure 6-3-11.
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Figure 6-3-11 Setting ex-6321 communication parameters

Table 6-3-10 lists the configurable parameters of ex-6321, such as baud rate, parity check,
stop bit, and communication timeout

Table 6-3-10 Definitions of communication parameters

The
serial
number

parameter instructions
note

1 BaudRate Baud rate Users can choose standard baud rate
2 Data Bits Data bits Fixed for 8 bit
3 Patity Bits parity This parameter is configurable by default
4 Stop Bits Stop bit The default value is 1 bit
5 Reapons Timeout timeout Communication timeout value, in ms

6 Char Pitch
Characters in

length
The default value is 5char, which is

configurable

Table 6-3-11 describes the functions of the EX-6321 INPUT and output addresses

Table 6-3-11 Functions of the INPUT and output addresses and their descriptions

The
serial
number

parameter instructions
note

Output area (Q area)
The
serial

pin instructions
note
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number

1 Send_Enable Data sent
0 to 1: data is sent

1 to 0: sending is disabled
2 Slave_ID Modbus slave address 1-255.

3 Funtion Mdobus function code
Support function code:
01/02/03/04/05/06/15/16

4 Address Slave register address 0-65535.

5
Coil Or Register

Quantity
The length of data read or

written
Length value: 1-4

6 Data Out 0
The master station sends

data #1
Valid only for register

writing
7 Data Out 1 The master sends data #2
8 Data Out 2 The master sends data #3
9 Data Out 3 The master sends data #4

Output area (I area)
The
serial
number

pin instructions
note

1
Modbus Data Send

Flag
Send complete flag bit 0 to 1: Data is sent

2
Modbus Data
Receive Flag

Receive completion flag
bit

0→1: Data is received

3
Modbus Slave
Station Num

Modbus RTU returns
from the secondary

address
Returns the slave address

4 Modbus Error Code
Modbus RTU

communication error code
0: The communication is

normal

5 Data In 0
Return data #1 from the

station

The read slave register data
is returned

6 Data In 1
Return data #2 from the

station

7 Data In 2
Return data #3 from the

station

8 Data In 3
Return data #4 from the

station

For example, read Modbus RTU slave station #1 register 400001/40002/40003/40004:

Slave_ID -- "1"

Funtion - 03 (03 Function Code Reading)

Address - "00" (start Address 40001 corresponds to Address 0)

Coil Or Register Quantity -- 04
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Send_Enable -- TRUE (Sending data)

The data returned from station #1 in register 40001/40002/40003/40004 are stored in:

Data In 0, Data In 1, Data In 2, Data In 3.

For example, write data to Modbus RTU slave station #2 register 40010/40011/40012/40013
to 100, 3000, 80, 300 respectively:

Slave_ID -- "2"

Funtion - 16 (03 Function Code Reading)

Address - "00" (start Address 40001 corresponds to Address 0)

Coil Or Register Quantity -- 04

Data Out 0-100

Data Out 1 -- 3000

Data Out 2 -- 80

Data Out 3 -- 300

Send_Enable -- TRUE (Sending data)

Note: Send_Enable pin from 10, Data out1-out4 Data will be cleared automatically

6.3.6 Setting the IP address of the EX-1121 Adapter

The DIP codes for the EX-1121 adapter are defined as follows:

IPAddress
Hundred
Bits×100

IPAddress ten
Bits×10

IP Address
Bit×1

Figure 6-3-12 DIP switch of the EX-1121 adapter

Dip switch definition

Three combination
dip set values

IP address setting method
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0 Set through BOOTP.
001-254. Set the low 1byte of the IP address by turning the switch.

More than 255
The module status indicator (MS) is blinking red because the

Settings are incorrect

(1) Through BOOTP

When setting the IP address through BOOTP, the three DIP switches of the adapter must be 0
before power-on. Run the IP Seting Tool software to scan for the online EX-1121 adapter, as
shown in Figure 6-3-13.To configure the IP address of the module, double-click the EX-1121
adapter that needs to be configured with an IP address and configure the IP address, as shown in
Figure 6-3-14.After the IP address is set, the software prompts that the IP address is set, as shown
in Figure 6-3-15. Figure 6-3-16 shows the process for setting an IP address through BOOTP.

Note: When the IP address is first set in BOOTPmode, the three DIP switches must be 0.When an IP
address has been set through BOOTP, the IP address is set through the rotation switch along with
the high byte of the IP address set through BOOTP, and the low byte of the IP address becomes the
set value of the rotation switch.

Figure 6-3-13 Scanning EtherNet/IP devices
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Figure 6-3-14 Setting the IP address

Figure 6-3-15 IP address setting completed

The three DIP switches are
0. Power on and restart UP Steing Tool IP address for

example, 192.168.1.156

Set the DIP switch combination to
225. If the power is off and the system
restarts, the IP address of EX-1121 is

192.168.1.225

Set the COMBINATION of DIP
switch Settings to D. After the system
restarts, the IP address is restored to

192.168.1.156

Figure 6-3-16 Setting the IP address using BOOTP

(2) Set by dip switch

Set the IP address using dip switches. The combination of the first three DIP switches is not 0
(1-254). Start the IP Seting Tool software and scan for the online EX-1121 adapter, as shown in
Figure 6-3-17.To configure the IP address of the module, double-click the EX-1121 adapter to be
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configured with an IP address and configure the IP address, as shown in Figure 6-3-18.After the
IP address is set, the software prompts you that the IP address is set, as shown in Figure 6-3-19.
Figure 6-3-20 shows the process for setting an IP address through BOOTP.

Note: The PC IPv4 network segment must be in the same network segment (192.168.0.x) as the
EX-1121 adapter when you first set the IP address using the DIP switch.

Figure 6-3-17 Scanning EtherNet/IP devices

Figure 6-3-18 Modifying the module network segment
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Figure 6-3-19 IP address setting completed

The combination of the three DIP switches is
not 0(1254), and the system is powered on
and restarted (default network segment:
192.168.0.x).

IP Steing Tool Set the IP address segment
of the module to 192.168.1.x

Set the DIP switch combination to 225. If
the power is off and the system restarts,
the IP address of EX-1121 is
192.168.1.225

Figure 6-3-20 Setting the IP network segment using DIP switches

The Appendix

1. Modbus address table of ex-1030 module

Register
address

Data area Description note

0x0000
0x00FF

Input process
data area

Input process
data area

0x0800
0x08FF

Output
process data
area

Output process
data area

0x1000-
0x1006

Read-only
diagnostic
data area 1

MODBUS
indicates the
name

The character is ex-1030. Unused characters are filled
with 0

0x1007
Software
Version number

A value of 0x1000 indicates version V1.0.0.0

0x1008
Hardware
Version number

Same as above

0x1009- keep
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0x100E

0x100F
RTU coupler
status

Bit0 is the local bus state (a value of 1 indicates that
the local bus is abnormal)
Bit15 is the fieldbus state (a value of 1 means
watchdog times out)
Other bits reserved

0x1010

Slave status
(high 1 byte)
Number of slave
stations (low 1
byte)

Slave state:
0-Connect
to normal

1- Disconnect from the station

0x1011

The total byte
size of the data
area occupied
by the analog
output

For example, if a 4-channel AO module is connected
and a single channel occupies 2 bytes, the value of this
item is 8

0x1012

The total size of
the data area
occupied by the
analog input in
bytes

For example, if a four-channel AI module is connected
and a single channel occupies 2 bytes, the value of this
item is 8

0x1013

The total size in
bytes of the data
area occupied
by the digital
output

If the 8-channel DO module is connected, the data
should be 1 byte

0x1014

The total size of
the data area
occupied by the
digital input in
bytes

For example, if a 7-channel DI module is connected,
the value of this item is 1 byte. If the value is less than
8 bits, the value is 8 bits

0x1015
Current
watchdog time
ms

It can be set by dip switch or address 0x2000

0x1016
The topology of
1

Module ID(2 bytes). Each model has a unique ID. If
IO exists, the module ID is displayed; if no module
exists, 0 is displayed.

0x1017
The topology of
2

Same as above

-- --

0x1035
The topology of
32

Same as above
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0x2000

Read
(0x03)/write
(0x10)
configuration
data area

Set watchdog
time ms.
Watchdog is
disabled by
factory default

The maximum support is 65000MS and the minimum
unit is 100ms.
0 indicates that the watchdog function is disabled

0x2001
The watchdog
resets the
register

You must use function code 06 or 0F and write the
value 0xAE01 first and then 0xAE02

0x2002 Watchdog type
0-Indicates packet watchdog (default)
1-Indicates that the watchdog writes packets
See Note 1

0x2003 Check digit
0-No check
1-Odd parity

2-Parity checking

0x2004 Stop bit
1-1 stop bit
2-2 stop bits

0x2005 Frame end time
Ms (default 0, depending on baud rate, other values

such as 1, 1ms, maximum 10ms)

Note 1:

Guard dog

The watchdog is disabled in factory Settings.The watchdog can be enabled by writing time (say 1000ms) to
address 0x2000.The watchdog registers (0x2000, 0x2002) are written and restart to take effect.The data in this
register is reserved.

After receiving the request packet for the first time, the watchdog timer is started. After receiving the request
packet, the watchdog timer is triggered again.In the second method, after the first telegram is written, the
watchdog timer starts and is triggered each time a written telegram is received from the device.To do this, write
1 to register 0x2002(default "0").If the slave's watchdog timer has expired, it can be rewritten by writing twice
to register 0x2001.This must be written to the register by function code 06 or 0F :0xAE01 0xAE02.

Note 2.

All configuration data areas except reset watchdog register (0x2001) Settings do not need to be powered off, all
other Settings need to be powered off to take effect.

2. Order information of remote IO products

Product
model

The product description
The order

no.

The adapter
EX-1010 DeviceNet adapter 02-01-01
EX-1130 Modbus TCP adapter 02-01-07
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EX-1030 Modbus RTU adapter 02-01-03
EX-1100 EtherCAT adapter 02-01-04
EX-1110 PROFINET adapter 02-01-05
EX-1112 PROFINET adapter 02-01-05-1
EX-1040 CC - Link adapter 02-01-06
EX-1120 EtherNet/IP adapter 02-01-08
EX-1121 EtherNet/IP adapter 02-01-08-1
EX-1140 CC-link IE Filed Basic 02-01-09

Digital input module
EX-2008 8 channel digital input module NPN type 02-02-01
EX-2108 8 channel digital input module PNP type 02-02-02
EX-200H 16 channel digital input module NPN type 02-02-03
EX-210H 16 channel digital input module PNP type 02-02-04

EX-2C0S
32 channel digital input module NPN&PNP

compatible
02-02-05

Digital output module
EX-3008 8-channel digital output module NPN type 02-03-01
EX-3108 8 channel digital output module PNP type 02-03-02
EX-300H 16 channel digital output module NPN type 02-03-03
EX-310H 16 channel digital output module PNP type 02-03-04
EX-3208 8 channel relay output module 02-03-05
EX-300S 32 channel digital output module NPN type 02-03-06
EX-310S 32 channel digital output module PNP type 02-03-07

Analog input module

EX-4014
4-channel analog input module 0-10V 12-bit

accuracy 0.1%
02-04-01

EX-4014
4-channel analog input module 0-5V 12-bit

accuracy 0.1%
02-04-02

EX-4114
4-channel analog input module ±10V 12 bit

accuracy 0.1%
02-04-03

EX-4114
4-channel analog input module ±5V 12-bit accuracy

0.1%
02-04-04

EX-4054
4-channel analog input module 0-10V 16-bit

accuracy 0.02%
02-04-05

EX-4054
4-channel analog input module 0-5V 16-bit

accuracy 0.02%
02-04-06

EX-4154
4-channel analog input module ±10V 16-bit

accuracy 0.02%
02-04-07

EX-4154
4-channel analog input module ±5V 16-bit accuracy

0.02%
02-04-08

EX-4414
4-channel analog input module 4-20mA 12-bit

accuracy 0.1%
02-04-09
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EX-4414
4-channel analog input module 0-20mA 12-bit

accuracy 0.1%
02-04-10

EX-4454
4-channel analog input module 4-20mA 16-bit
accuracy 0.02%

02-04-11

EX-4454
4-channel analog input module 0-20mA 16-bit
accuracy 0.02%

02-04-12

EX-4018
8-channel analog input module 0-10V 12-bit

accuracy 0.1%
02-04-29

EX-4018
8-channel analog input module 0-5V 12-bit

accuracy 0.1%
02-04-30

EX-4118
8 channel analog input module ±10V 12 bit

accuracy 0.1%
02-04-31

EX-4118
8 channel analog input module ±5V 12 bit accuracy

0.1%
02-04-32

EX-4418
8-channel analog input module 4-20mA 12-bit

accuracy 0.1%
02-04-33

EX-4418
8-channel analog input module 0-20mA 12-bit

accuracy 0.1%
02-04-34

Thermocouple (TC) input module

EX-4654
4 channel thermocouple (TC) input module (2 wire)

TYPE K
02-04-13

EX-4654
4 channel thermocouple (TC) input module (2 wire)

J
02-04-14

EX-4654
4 channel thermocouple (TC) input module (2 wire)

Model T
02-04-15

EX-4654
4 channel thermocouple (TC) input module (2 wire)

Type E
02-04-16

EX-4654
4-channel thermocouple (TC) input module

(2-wire) Type N
02-04-17

EX-4654
4-channel thermocouple (TC) input module

(2-wire) model S
02-04-18

EX-4654
4-channel thermocouple (TC) input module

(2-wire) Type R
02-04-19

EX-4654
4 channel thermocouple (TC) input module (2 wire)

Type B
02-04-20

EX-4654
4 channel thermocouple (TC) input module (2 wire)

Type C
02-04-21

EX-4654
4 channel thermocouple (TC) input module (2 wire
system) voltage measurement

02-04-22

Thermal resistance (RTD) input module

EX-4754
4 channel thermal resistance (RTD) input module 2

wire or 3 wire (default 3 wire) PT100
02-04-23
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EX-4754
4 channel thermal resistance (RTD) input module 2

wire or 3 wire (default 3 wire) PT200
02-04-24

EX-4754
4 channel thermal resistance (RTD) input module 2

wire or 3 wire (default 3 wire) PT500
02-04-25

EX-4754
4-channel thermal resistance (RTD) input module

2-wire or 3-wire PT1000 (default 3-wire)
02-04-26

EX-4754
4 channel thermal resistance (RTD) input module 2

wire or 3 wire (default 3 wire) Ni120
02-04-27

EX-4754
4 channel thermal resistance (RTD) input module 2

wire or 3 wire system (default 3 wire system)
resistance measurement

02-04-28

Analog output module

EX-5014
4-channel analog output module 0-10V 12-bit

accuracy 0.1%
02-05-01

EX-5014
4-channel analog output module 0-5V 12-bit

accuracy 0.1%
02-05-02

EX-5114
4-channel analog output module ±10V 12 bit

accuracy 0.1%
02-05-03

EX-5114
4-channel analog output module ±5V 12 bit

accuracy 0.1%
02-05-04

EX-5054
4-channel analog output module 0-10V 16-bit

accuracy 0.02%
02-05-05

EX-5054
4-channel analog output module 0-5V 16-bit

accuracy 0.02%
02-05-06

EX-5154
4-channel analog output module ±10V 16-bit

accuracy 0.02%
02-05-07

EX-5154
4-channel analog output module ±5V 16-bit

accuracy 0.02%
02-05-08

EX-5414
4-channel analog output module 4-20mA 12-bit

accuracy 0.1%
02-05-09

EX-5414
4-channel analog output module 0-20mA 12-bit

accuracy 0.1%
02-05-10

EX-5454
4-channel analog output module 4-20mA 16-bit
accuracy 0.02%

02-05-11

EX-5454
4-channel analog output module 0-20mA 16-bit
accuracy 0.02%

02-05-12

EX-5018
8-channel analog output module 0-10V 12 bit

accuracy 0.1%
02-05-13

EX-5018
8-channel analog output module 0-5V 12-bit

accuracy 0.1%
02-05-14

EX-5118
8-channel analog output module ±10V 12 bit

accuracy 0.1%
02-05-15
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EX-5118
8-channel analog output module ±5V 12 bit

accuracy 0.1%
02-05-16

EX-5418
8-channel analog output module 4-20mA 12-bit

accuracy 0.1%
02-05-17

EX-5418
8-channel analog output module 0-20mA 12-bit

accuracy 0.1%
02-05-18

Function module
EX-6001 Single-channel NPN encoder module 02-06-01
EX-6011 Single channel PNP encoder module 02-06-02
EX-6021 Single channel differential encoder module 02-06-03
EX-6101 Single channel NPN pulse output module 02-06-07
EX-6111 Single channel PNP pulse output module 02-06-08
EX-6121 Single channel differential pulse output module 02-06-09
EX-6301 1 channel 485 free port communication module 02-06-12
EX-6311 1 channel 232 free port communication module 02-06-13
EX-6321 1 Modbus RTU Mater communication module 02-06-14
EX-TER01 Terminal module 02-00-00
EX-0100 System power supply and I/O power module 02-00-01
EX-0300 I/O power module 02-00-03

accessories
cable Bt04-100 40P cable 10-02-00

Terminal
station

AT04 10-02-01
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